emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Re: No indentation for all paragraph
@ 2009-05-12  9:32 Giovanni Ridolfi
  2009-05-12 10:08 ` Jan Buchal
  0 siblings, 1 reply; 14+ messages in thread
From: Giovanni Ridolfi @ 2009-05-12  9:32 UTC (permalink / raw)
  To: Sebastian Rose, Jan Buchal; +Cc: Bastien, Org-mode ml


> >>>>> "SR" ==
> Sebastian Rose <sebastian_rose@gmx.de>
> writes:
> 
>     SR> Try
> 
>     SR> \setlength{\parindent}{0em}
> 
> Yes, it works fine for PDf but if I want export the same
> file to HTML
> then in HTML file is this latex command displayed. Is it
> possible say
> that this line has not be exported to HTML?

what about

#+BEGIN_LaTeX
\setlength{\parindent}{0em}
#+END_LaTeX

Giovanni




^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12  9:32 No indentation for all paragraph Giovanni Ridolfi
@ 2009-05-12 10:08 ` Jan Buchal
  2009-05-12 11:13   ` Sebastian Rose
  0 siblings, 1 reply; 14+ messages in thread
From: Jan Buchal @ 2009-05-12 10:08 UTC (permalink / raw)
  To: Giovanni Ridolfi; +Cc: Bastien, Org-mode ml

>>>>> "GR" == Giovanni Ridolfi <giovanni.ridolfi@yahoo.it> writes:

    >> >>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:
    >> 
    >>     SR> Try
    >> 
    >>     SR> \setlength{\parindent}{0em}
    >> 
    >> Yes, it works fine for PDf but if I want export the same file to
    >> HTML then in HTML file is this latex command displayed. Is it
    >> possible say that this line has not be exported to HTML?

    GR> what about

    GR> #+BEGIN_LaTeX \setlength{\parindent}{0em} #+END_LaTeX

    GR> Giovanni
Yes, perfect. And if I want that clocking line will be displayed in HTML
or PDF exported file? For example:

* Summary of time

  CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] =>  0:40


Best

-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 10:08 ` Jan Buchal
@ 2009-05-12 11:13   ` Sebastian Rose
  2009-05-12 11:22     ` Sebastian Rose
  2009-05-12 11:34     ` Jan Buchal
  0 siblings, 2 replies; 14+ messages in thread
From: Sebastian Rose @ 2009-05-12 11:13 UTC (permalink / raw)
  To: Jan Buchal; +Cc: Bastien, Org-mode ml

Jan Buchal <buchal@brailcom.org> writes:
>>>>>> "GR" == Giovanni Ridolfi <giovanni.ridolfi@yahoo.it> writes:
>
>     >> >>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:
>     >> 
>     >>     SR> Try
>     >> 
>     >>     SR> \setlength{\parindent}{0em}
>     >> 
>     >> Yes, it works fine for PDf but if I want export the same file to
>     >> HTML then in HTML file is this latex command displayed. Is it
>     >> possible say that this line has not be exported to HTML?
>
>     GR> what about
>
>     GR> #+BEGIN_LaTeX \setlength{\parindent}{0em} #+END_LaTeX
>
>     GR> Giovanni
> Yes, perfect. And if I want that clocking line will be displayed in HTML
> or PDF exported file? For example:
>
> * Summary of time
>
>   CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] =>  0:40
>
>
> Best


Do an

  M-x customize-variable RET org-export-with- TAB

to see all (global) options related to this topic.


You can set this in the #+OPTIONS: line per file (see
http://orgmode.org/manual/Export-options.html#Export-options):

#+OPTIONS: <:t







Regards


   Sebastian

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 11:13   ` Sebastian Rose
@ 2009-05-12 11:22     ` Sebastian Rose
  2009-05-12 11:34     ` Jan Buchal
  1 sibling, 0 replies; 14+ messages in thread
From: Sebastian Rose @ 2009-05-12 11:22 UTC (permalink / raw)
  To: Jan Buchal; +Cc: Bastien, Org-mode ml


Forgot: just in case you're not aware of this:

Once you change something in the #+OPTIONS: line, stay there and pre
`C-c C-c' to make Org update the local settings.


Best


   Sebastian

Sebastian Rose <sebastian_rose@gmx.de> writes:
> Jan Buchal <buchal@brailcom.org> writes:
>>>>>>> "GR" == Giovanni Ridolfi <giovanni.ridolfi@yahoo.it> writes:
>>
>>     >> >>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:
>>     >> 
>>     >>     SR> Try
>>     >> 
>>     >>     SR> \setlength{\parindent}{0em}
>>     >> 
>>     >> Yes, it works fine for PDf but if I want export the same file to
>>     >> HTML then in HTML file is this latex command displayed. Is it
>>     >> possible say that this line has not be exported to HTML?
>>
>>     GR> what about
>>
>>     GR> #+BEGIN_LaTeX \setlength{\parindent}{0em} #+END_LaTeX
>>
>>     GR> Giovanni
>> Yes, perfect. And if I want that clocking line will be displayed in HTML
>> or PDF exported file? For example:
>>
>> * Summary of time
>>
>>   CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] =>  0:40
>>
>>
>> Best
>
>
> Do an
>
>   M-x customize-variable RET org-export-with- TAB
>
> to see all (global) options related to this topic.
>
>
> You can set this in the #+OPTIONS: line per file (see
> http://orgmode.org/manual/Export-options.html#Export-options):
>
> #+OPTIONS: <:t

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 11:13   ` Sebastian Rose
  2009-05-12 11:22     ` Sebastian Rose
@ 2009-05-12 11:34     ` Jan Buchal
  2009-05-12 13:06       ` Sebastian Rose
  1 sibling, 1 reply; 14+ messages in thread
From: Jan Buchal @ 2009-05-12 11:34 UTC (permalink / raw)
  To: Sebastian Rose; +Cc: Bastien, Org-mode ml

[-- Attachment #1: Type: text/plain, Size: 818 bytes --]

>>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:

[....]

    >> Yes, perfect. And if I want that clocking line will be displayed
    >> in HTML or PDF exported file? For example:
    >> 
    >> * Summary of time
    >> 
    >> CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] => 0:40

    SR> Do an

    SR> M-x customize-variable RET org-export-with- TAB

    SR> to see all (global) options related to this topic.


    SR> You can set this in the #+OPTIONS: line per file (see
    SR> http://orgmode.org/manual/Export-options.html#Export-options):

    SR> #+OPTIONS: <:t
I added this line in my .org file but still in HTML and PDF CLOCK is not
dysplayed. What I make wrong?

In attached file is example of my .org file.


Thanks.


-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021


[-- Attachment #2: example.org --]
[-- Type: application/octet-stream, Size: 291 bytes --]

#+TITLE: Zápis z teleporady 2009-05-11
#+AUTHOR: Jan Buchal
#+EMAIL: buchal@brailcom.org
#+LANGUAGE:  cs
#+BEGIN_LaTeX
\setlength{\parindent}{0em}
#+END_LaTeX
#+OPTIONS:   <:t

* Start and finisch <2009-05-11 Po>

  CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] =>  0:40

Some text.


[-- Attachment #3: Type: text/plain, Size: 204 bytes --]

_______________________________________________
Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.
Emacs-orgmode@gnu.org
http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 11:34     ` Jan Buchal
@ 2009-05-12 13:06       ` Sebastian Rose
  2009-05-12 13:13         ` Carsten Dominik
  0 siblings, 1 reply; 14+ messages in thread
From: Sebastian Rose @ 2009-05-12 13:06 UTC (permalink / raw)
  To: Jan Buchal; +Cc: Bastien, Org-mode ml


Here it nearly works, when I set `org-clock-into-drawer' to `t' and
`org-export-with-drawers' to `All drawers'.
Or per file:

     #+OPTIONS:   <:t d:t




<p>
:LOGBOOK:
:END:
</p>



Hm - the time is still missing...


Is this a bug or did I miss something?


I didin't export with clocks for quite some time. But I know it worked
half a year ago....

Now I get things like this all over the place:

:LOGBOOK:
:END:
:PROPERTIES:
:Effort:   16:00
:END:



  Sebastian





Jan Buchal <buchal@brailcom.org> writes:
>>>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:
>
> [....]
>
>     >> Yes, perfect. And if I want that clocking line will be displayed
>     >> in HTML or PDF exported file? For example:
>     >> 
>     >> * Summary of time
>     >> 
>     >> CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] => 0:40
>
>     SR> Do an
>
>     SR> M-x customize-variable RET org-export-with- TAB
>
>     SR> to see all (global) options related to this topic.
>
>
>     SR> You can set this in the #+OPTIONS: line per file (see
>     SR> http://orgmode.org/manual/Export-options.html#Export-options):
>
>     SR> #+OPTIONS: <:t
> I added this line in my .org file but still in HTML and PDF CLOCK is not
> dysplayed. What I make wrong?
>
> In attached file is example of my .org file.
>
>
> Thanks.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 13:06       ` Sebastian Rose
@ 2009-05-12 13:13         ` Carsten Dominik
  2009-05-12 13:26           ` Jan Buchal
  0 siblings, 1 reply; 14+ messages in thread
From: Carsten Dominik @ 2009-05-12 13:13 UTC (permalink / raw)
  To: Sebastian Rose; +Cc: Bastien, Org-mode ml

Clock lines are always removed, never published.  The never
look nice when published.

I'd recommend using a clock table to capture the necessary stuff.

Is people insist, we can go back to have a variable to publish the  
clock lines.

- Carsten

On May 12, 2009, at 3:06 PM, Sebastian Rose wrote:

>
> Here it nearly works, when I set `org-clock-into-drawer' to `t' and
> `org-export-with-drawers' to `All drawers'.
> Or per file:
>
>     #+OPTIONS:   <:t d:t
>
>
>
>
> <p>
> :LOGBOOK:
> :END:
> </p>
>
>
>
> Hm - the time is still missing...
>
>
> Is this a bug or did I miss something?
>
>
> I didin't export with clocks for quite some time. But I know it worked
> half a year ago....
>
> Now I get things like this all over the place:
>
> :LOGBOOK:
> :END:
> :PROPERTIES:
> :Effort:   16:00
> :END:
>
>
>
>  Sebastian
>
>
>
>
>
> Jan Buchal <buchal@brailcom.org> writes:
>>>>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:
>>
>> [....]
>>
>>>> Yes, perfect. And if I want that clocking line will be displayed
>>>> in HTML or PDF exported file? For example:
>>>>
>>>> * Summary of time
>>>>
>>>> CLOCK: [2009-05-11 Po 11:00]--[2009-05-11 Po 11:40] => 0:40
>>
>>    SR> Do an
>>
>>    SR> M-x customize-variable RET org-export-with- TAB
>>
>>    SR> to see all (global) options related to this topic.
>>
>>
>>    SR> You can set this in the #+OPTIONS: line per file (see
>>    SR> http://orgmode.org/manual/Export-options.html#Export-options):
>>
>>    SR> #+OPTIONS: <:t
>> I added this line in my .org file but still in HTML and PDF CLOCK  
>> is not
>> dysplayed. What I make wrong?
>>
>> In attached file is example of my .org file.
>>
>>
>> Thanks.
>
>
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> Emacs-orgmode@gnu.org
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-12 13:13         ` Carsten Dominik
@ 2009-05-12 13:26           ` Jan Buchal
  0 siblings, 0 replies; 14+ messages in thread
From: Jan Buchal @ 2009-05-12 13:26 UTC (permalink / raw)
  To: Carsten Dominik; +Cc: Bastien, Org-mode ml

>>>>> "CD" == Carsten Dominik <carsten.dominik@gmail.com> writes:

    CD> Clock lines are always removed, never published. The never look
    CD> nice when published.
:-)

    CD> I'd recommend using a clock table to capture the necessary
    CD> stuff.
Yes, it is possible but it seams too not nice :-) and more complicate.

    CD> Is people insist, we can go back to have a variable to publish
    CD> the clock lines.
I think if a choice exist is better then not.

Best

-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-11 18:32       ` Sebastian Rose
@ 2009-05-12  9:01         ` Jan Buchal
  0 siblings, 0 replies; 14+ messages in thread
From: Jan Buchal @ 2009-05-12  9:01 UTC (permalink / raw)
  To: Sebastian Rose; +Cc: Bastien, Org-mode ml

>>>>> "SR" == Sebastian Rose <sebastian_rose@gmx.de> writes:

    SR> Try

    SR> \setlength{\parindent}{0em}

Yes, it works fine for PDf but if I want export the same file to HTML
then in HTML file is this latex command displayed. Is it possible say
that this line has not be exported to HTML?

-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-11 17:12     ` Jan Buchal
@ 2009-05-11 18:32       ` Sebastian Rose
  2009-05-12  9:01         ` Jan Buchal
  0 siblings, 1 reply; 14+ messages in thread
From: Sebastian Rose @ 2009-05-11 18:32 UTC (permalink / raw)
  To: Jan Buchal; +Cc: Bastien, Org-mode ml


Try

\setlength{\parindent}{0em}

There might be some more required. But this is all I do and it should be
enough for the `article' class.


Regards

   Sebastian

Jan Buchal <buchal@brailcom.org> writes:
>>>>>> "B" == Bastien  <bastienguerry@googlemail.com> writes:
>
>     B> Jan Buchal <buchal@brailcom.org> writes:
>     JB> and I would like have all these paragraphs indented to the left
>     JB> without a space
>     >> 
>     >> I mean for HTML or PDF export.
>
>     B> To my knowledge, paragraphs are not indented by default in HTML.
>
> Yes, you are right. My problem is in PDF.
>
>     B> If you want to explicitely force indentation to be 0, use a style
>     B> specification like this:
>
>     B> .p {text-indent:0;}
>
>     B> In PDF (as processed by LaTeX), indentation depends on the
>     B> documentclass you are using in the LaTeX source.
> I don't understand where I can change it?
>
> Thanks

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-11 16:06   ` Bastien
@ 2009-05-11 17:12     ` Jan Buchal
  2009-05-11 18:32       ` Sebastian Rose
  0 siblings, 1 reply; 14+ messages in thread
From: Jan Buchal @ 2009-05-11 17:12 UTC (permalink / raw)
  To: Bastien; +Cc: Org-mode ml

>>>>> "B" == Bastien  <bastienguerry@googlemail.com> writes:

    B> Jan Buchal <buchal@brailcom.org> writes:
    JB> and I would like have all these paragraphs indented to the left
    JB> without a space
    >> 
    >> I mean for HTML or PDF export.

    B> To my knowledge, paragraphs are not indented by default in HTML.

Yes, you are right. My problem is in PDF.

    B> If you want to explicitely force indentation to be 0, use a style
    B> specification like this:

    B> .p {text-indent:0;}

    B> In PDF (as processed by LaTeX), indentation depends on the
    B> documentclass you are using in the LaTeX source.
I don't understand where I can change it?

Thanks


-- 
Jan Buchal
Tel: +420242486008
Mob: +420608023021
http://www.brailcom.org

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-11 13:57 ` Jan Buchal
@ 2009-05-11 16:06   ` Bastien
  2009-05-11 17:12     ` Jan Buchal
  0 siblings, 1 reply; 14+ messages in thread
From: Bastien @ 2009-05-11 16:06 UTC (permalink / raw)
  To: Jan Buchal; +Cc: Org-mode ml

Jan Buchal <buchal@brailcom.org> writes:

>     JB> and I would like have all these paragraphs indented to the left
>     JB> without a space
>
> I mean for HTML or PDF export.

To my knowledge, paragraphs are not indented by default in HTML.  If you
want to explicitely force indentation to be 0, use a style specification
like this:

  .p {text-indent:0;}

In PDF (as processed by LaTeX), indentation depends on the documentclass
you are using in the LaTeX source.  

-- 
 Bastien

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: No indentation for all paragraph
  2009-05-11 13:47 Jan Buchal
@ 2009-05-11 13:57 ` Jan Buchal
  2009-05-11 16:06   ` Bastien
  0 siblings, 1 reply; 14+ messages in thread
From: Jan Buchal @ 2009-05-11 13:57 UTC (permalink / raw)
  To: Org-mode ml

>>>>> "JB" == Jan Buchal <buchal@brailcom.org> writes:

    JB> Hello, is it possible set for all document that all paragraphs
    JB> will be without indentation?

    JB> I have many headings with short text for example:

    JB> * level 1


    JB> first paragraph

    JB> Second paragraph

    JB> ** level 1.1

    JB> first paragraph

    JB> Second paragraph

    JB> etc...

    JB> and I would like have all these paragraphs indented to the left
    JB> without a space

I mean for HTML or PDF export.


-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021

^ permalink raw reply	[flat|nested] 14+ messages in thread

* No indentation for all paragraph
@ 2009-05-11 13:47 Jan Buchal
  2009-05-11 13:57 ` Jan Buchal
  0 siblings, 1 reply; 14+ messages in thread
From: Jan Buchal @ 2009-05-11 13:47 UTC (permalink / raw)
  To: Org-mode ml

Hello,

is it possible set for all document that all paragraphs will be without
indentation?

I have many headings with short text for example:

* level 1


first paragraph

Second paragraph

** level 1.1

first paragraph

Second paragraph

etc...

and I would like have all these paragraphs indented to the left without
a space

Thanks



thanks

-- 

Jan Buchal
Tel: (00420) 24 24 86 008
Mob: (00420) 608023021

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2009-05-12 13:28 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-05-12  9:32 No indentation for all paragraph Giovanni Ridolfi
2009-05-12 10:08 ` Jan Buchal
2009-05-12 11:13   ` Sebastian Rose
2009-05-12 11:22     ` Sebastian Rose
2009-05-12 11:34     ` Jan Buchal
2009-05-12 13:06       ` Sebastian Rose
2009-05-12 13:13         ` Carsten Dominik
2009-05-12 13:26           ` Jan Buchal
  -- strict thread matches above, loose matches on Subject: below --
2009-05-11 13:47 Jan Buchal
2009-05-11 13:57 ` Jan Buchal
2009-05-11 16:06   ` Bastien
2009-05-11 17:12     ` Jan Buchal
2009-05-11 18:32       ` Sebastian Rose
2009-05-12  9:01         ` Jan Buchal

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).