emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
@ 2021-11-02  8:18 Michael Maurer
  2021-11-02  8:36 ` Michael Maurer
  2021-11-02  8:41 ` Colin Baxter 😺
  0 siblings, 2 replies; 6+ messages in thread
From: Michael Maurer @ 2021-11-02  8:18 UTC (permalink / raw)
  To: emacs-orgmode

Subject line says it all, I upgraded to 9.5 two days ago and
everything seemed to work, but today I fire up the PC and C-c . no
longer is bound to anything. I guess I could custom-bind it in my
config, but I'm more interested in why it's happening. The last
package I installed after the upgrade was undo-fu and
undo-fu-sessions, but I dont' think they are involved.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
  2021-11-02  8:18 C-c . no longer inserts org-time-stamp (after upgrade to 9.5) Michael Maurer
@ 2021-11-02  8:36 ` Michael Maurer
  2021-11-02  8:39   ` Michael Maurer
  2021-11-02  8:41 ` Colin Baxter 😺
  1 sibling, 1 reply; 6+ messages in thread
From: Michael Maurer @ 2021-11-02  8:36 UTC (permalink / raw)
  To: emacs-orgmode

On Tue, 2 Nov 2021 at 09:18, Michael Maurer <maurer.michael@gmail.com> wrote:
>
> Subject line says it all, I upgraded to 9.5 two days ago and
> everything seemed to work, but today I fire up the PC and C-c . no
> longer is bound to anything. I guess I could custom-bind it in my
> config, but I'm more interested in why it's happening. The last
> package I installed after the upgrade was undo-fu and
> undo-fu-sessions, but I dont' think they are involved.

Update: After exiting and restarting Emacs, it works again. (?)


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
  2021-11-02  8:36 ` Michael Maurer
@ 2021-11-02  8:39   ` Michael Maurer
  0 siblings, 0 replies; 6+ messages in thread
From: Michael Maurer @ 2021-11-02  8:39 UTC (permalink / raw)
  To: emacs-orgmode

On Tue, 2 Nov 2021 at 09:36, Michael Maurer <maurer.michael@gmail.com> wrote:
>
> On Tue, 2 Nov 2021 at 09:18, Michael Maurer <maurer.michael@gmail.com> wrote:
> >
> > Subject line says it all, I upgraded to 9.5 two days ago and
> > everything seemed to work, but today I fire up the PC and C-c . no
> > longer is bound to anything. I guess I could custom-bind it in my
> > config, but I'm more interested in why it's happening. The last
> > package I installed after the upgrade was undo-fu and
> > undo-fu-sessions, but I dont' think they are involved.
>
> Update: After exiting and restarting Emacs, it works again. (?)

Update 2: No, it only seems to affect certain org-files, trying to
figure out why. Sorry for the spam!


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
  2021-11-02  8:18 C-c . no longer inserts org-time-stamp (after upgrade to 9.5) Michael Maurer
  2021-11-02  8:36 ` Michael Maurer
@ 2021-11-02  8:41 ` Colin Baxter 😺
  2021-11-02 15:23   ` Michael Maurer
  1 sibling, 1 reply; 6+ messages in thread
From: Colin Baxter 😺 @ 2021-11-02  8:41 UTC (permalink / raw)
  To: Michael Maurer; +Cc: , emacs-orgmode

>>>>> Michael Maurer <maurer.michael@gmail.com> writes:

    > Subject line says it all, I upgraded to 9.5 two days ago and
    > everything seemed to work, but today I fire up the PC and C-c . no
    > longer is bound to anything. I guess I could custom-bind it in my
    > config, but I'm more interested in why it's happening. The last
    > package I installed after the upgrade was undo-fu and
    > undo-fu-sessions, but I dont' think they are involved.

They could be. I don't have those packages and C-c . works for me and I
am running the latest git pull from org-mode. You might also have
multiple org files present.

Best wishes.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
  2021-11-02  8:41 ` Colin Baxter 😺
@ 2021-11-02 15:23   ` Michael Maurer
  2021-11-02 16:39     ` Mark Barton
  0 siblings, 1 reply; 6+ messages in thread
From: Michael Maurer @ 2021-11-02 15:23 UTC (permalink / raw)
  To: emacs-orgmode

On Tue, 2 Nov 2021 at 09:41, Colin Baxter 😺 <m43cap@yandex.com> wrote:
>
> >>>>> Michael Maurer <maurer.michael@gmail.com> writes:
>
>     > Subject line says it all, I upgraded to 9.5 two days ago and
>     > everything seemed to work, but today I fire up the PC and C-c . no
>     > longer is bound to anything. I guess I could custom-bind it in my
>     > config, but I'm more interested in why it's happening. The last
>     > package I installed after the upgrade was undo-fu and
>     > undo-fu-sessions, but I dont' think they are involved.
>
> They could be. I don't have those packages and C-c . works for me and I
> am running the latest git pull from org-mode. You might also have
> multiple org files present.
>
> Best wishes.

I figured it out. It's follow-mode. As soon as you enable it in a
buffer, C-c . stops working. I'm not sure if this incompatibility got
introduced with 9.5, since it's been years since I last used
follow-mode.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: C-c . no longer inserts org-time-stamp (after upgrade to 9.5)
  2021-11-02 15:23   ` Michael Maurer
@ 2021-11-02 16:39     ` Mark Barton
  0 siblings, 0 replies; 6+ messages in thread
From: Mark Barton @ 2021-11-02 16:39 UTC (permalink / raw)
  To: Michael Maurer; +Cc: emacs-orgmode

It looks like follow-mode-prefix is a variable you can customize. It defaults to "C-c .” which is why the org-time-stamp does not run with "C-c .”

To see the follow-mode-map use "M-x describe-keymap follow-mode-map”



> On Nov 2, 2021, at 8:23 AM, Michael Maurer <maurer.michael@gmail.com> wrote:
> 
> On Tue, 2 Nov 2021 at 09:41, Colin Baxter 😺 <m43cap@yandex.com> wrote:
>> 
>>>>>>> Michael Maurer <maurer.michael@gmail.com> writes:
>> 
>>> Subject line says it all, I upgraded to 9.5 two days ago and
>>> everything seemed to work, but today I fire up the PC and C-c . no
>>> longer is bound to anything. I guess I could custom-bind it in my
>>> config, but I'm more interested in why it's happening. The last
>>> package I installed after the upgrade was undo-fu and
>>> undo-fu-sessions, but I dont' think they are involved.
>> 
>> They could be. I don't have those packages and C-c . works for me and I
>> am running the latest git pull from org-mode. You might also have
>> multiple org files present.
>> 
>> Best wishes.
> 
> I figured it out. It's follow-mode. As soon as you enable it in a
> buffer, C-c . stops working. I'm not sure if this incompatibility got
> introduced with 9.5, since it's been years since I last used
> follow-mode.
> 



^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-11-02 17:00 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-02  8:18 C-c . no longer inserts org-time-stamp (after upgrade to 9.5) Michael Maurer
2021-11-02  8:36 ` Michael Maurer
2021-11-02  8:39   ` Michael Maurer
2021-11-02  8:41 ` Colin Baxter 😺
2021-11-02 15:23   ` Michael Maurer
2021-11-02 16:39     ` Mark Barton

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).