emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* problem with org-remember
@ 2010-03-06  2:40 Christian Wittern
  2010-03-06 10:34 ` Christian Wittern
  0 siblings, 1 reply; 7+ messages in thread
From: Christian Wittern @ 2010-03-06  2:40 UTC (permalink / raw)
  To: emacs-orgmode

Hi there,

Today I stumbled over a strange problem, to which I did not found a
solution.  I am using Emacs 23 on Mac OS X and on Ubuntu (9.10) with a
nearly identical setup (thanks Dropbox!).
On the Mac machines, remembering with org-remember works wonderful and
makes me happy; but on the Ubuntu side, I am running in an error
"wrong-number-of arguments", which can be traced to the following call
(org-remember-mode 1) in this form:

	;; Turn on org-mode in the remember buffer, set local variables
	(let ((org-inhibit-startup t)) (org-mode) (org-remember-mode 1))
	(if (and file (string-match "\\S-" file) (not (file-directory-p file)))
	    (org-set-local 'org-default-notes-file file))
---
  (this starts on line 543 in the current version of this morning)

The call itself looks unsuspicious to my inexperienced I and I have
now idea why Emacs would complain about it in Ubuntu and not in Mac
(there is a very slight difference of about two weeks between
compiling them), so I really have no idea what went wrong and how to
fix it.

As always, any help appreciated,

Christian
-- 
Christian Wittern, Kyoto

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: problem with org-remember
  2010-03-06  2:40 problem with org-remember Christian Wittern
@ 2010-03-06 10:34 ` Christian Wittern
  0 siblings, 0 replies; 7+ messages in thread
From: Christian Wittern @ 2010-03-06 10:34 UTC (permalink / raw)
  To: emacs-orgmode

Replying to myself here, Mr Google told me that this seems to be a bug
in my Emacs version.  Recompiling a more recent pretest made the
problem go away.  Sorry for the noise and happy orging,

Christian

On 6 March 2010 11:40, Christian Wittern <cwittern@gmail.com> wrote:
> Hi there,
>
> Today I stumbled over a strange problem, to which I did not found a
> solution.  I am using Emacs 23 on Mac OS X and on Ubuntu (9.10) with a
> nearly identical setup (thanks Dropbox!).
> On the Mac machines, remembering with org-remember works wonderful and
> makes me happy; but on the Ubuntu side, I am running in an error
> "wrong-number-of arguments", which can be traced to the following call
> (org-remember-mode 1) in this form:
>
>        ;; Turn on org-mode in the remember buffer, set local variables
>        (let ((org-inhibit-startup t)) (org-mode) (org-remember-mode 1))
>        (if (and file (string-match "\\S-" file) (not (file-directory-p file)))
>            (org-set-local 'org-default-notes-file file))
> ---
>  (this starts on line 543 in the current version of this morning)
>
> The call itself looks unsuspicious to my inexperienced I and I have
> now idea why Emacs would complain about it in Ubuntu and not in Mac
> (there is a very slight difference of about two weeks between
> compiling them), so I really have no idea what went wrong and how to
> fix it.
>
> As always, any help appreciated,
>
> Christian
> --
> Christian Wittern, Kyoto
>



-- 
Christian Wittern, Kyoto

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-remember
       [not found]         ` <9717.1232400732@alphaville.usa.hp.com>
@ 2009-01-19 22:09           ` Mark Elston
  0 siblings, 0 replies; 7+ messages in thread
From: Mark Elston @ 2009-01-19 22:09 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: Org Mode List

Nick,

I'm always glad to be of service ... :)

Thanks for helping me track this all down.

Mark

* Nick Dokos wrote (on 1/19/2009 1:32 PM):
> Mark Elston <m.elston@advantest-ard.com> wrote:
> 
>> I got it working.  As I was looking at my .emacs I noticed that I
>> had commented out the line:
>>
>>   (org-remember-insinuate)
>>
>> Once I uncommented this line it worked as expected.  I see that
>> this function does largely what yours does.
>>
> 
> Nice! I can now simplify my setup as well: I didn't know about
> org-remember-insinuate.
> 
> 
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-remember
       [not found]     ` <9099.1232399183@alphaville.usa.hp.com>
@ 2009-01-19 21:19       ` Mark Elston
       [not found]         ` <9717.1232400732@alphaville.usa.hp.com>
  0 siblings, 1 reply; 7+ messages in thread
From: Mark Elston @ 2009-01-19 21:19 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: Org Mode List

Nick,

I got it working.  As I was looking at my .emacs I noticed that I
had commented out the line:

   (org-remember-insinuate)

Once I uncommented this line it worked as expected.  I see that
this function does largely what yours does.

And, yes, I see the mention of org-install in sec 1.2.
I had a mixture of docs I was working with originally and
missed that line in the new docs...

Mark

* Nick Dokos wrote (on 1/19/2009 1:06 PM):
> Mark Elston <m.elston@advantest-ard.com> wrote:
> 
>> Nick,
>>
>> It helps with the first problem, the autoload problem.  I didn't see
>> this in the manual anywhere.
>>
> It's mentioned in the Installation section (sec. 1.2).
> 
>> However, while it brings up a *Remember* window it doesn't populate
>> it with any of the templates I have set up (basically I copied what was
>> in the texinfo doc).  And when I write something in it and hit
>> C-cC-c I get an error:
>>
>>   Debugger entered--Lisp error: (error "The mark is not set now, so
>> there is no region")
>>   call-interactively(comment-region)
>>
>> This is not what I expected from the docs.
>>
> 
> You probably want to set debug-on-error to t and try it again. You should
> get a backtrace that will tell more of the story.
> 
> However, you might want to give the following a try: it's a
> stripped-down version of my org initialization. Can you try it after
> changing the paths?
> 
> -------------------------------------------------------------------------------------
> ;; change the path appropriately.
> (add-to-list 'load-path (expand-file-name "~/src/emacs/org/git/org-mode/lisp"))
> 
> (require 'org-install)
> 
> ;;; org mode
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> (define-key global-map "\C-cl" 'org-store-link)
> (define-key mode-specific-map [?a] 'org-agenda)
> 
> ;;; remember
> ;; change the path appropriately
> (add-to-list 'load-path "/usr/local/share/emacs/site-lisp/remember")
> (require 'remember)
> (add-hook 'remember-mode-hook 'org-remember-apply-template)
> 
> (setq org-remember-templates
>       '(("Todo" ?t "* TODO %?\n  %i\n  %a" "~/org/TODO.org" "Tasks")
>         ("Journal" ?j "* %U %?\n\n  %i\n  %a" "~/org/JOURNAL.org")
>         ("Idea" ?i "* %^{Title}\n  %i\n  %a" "~/org/JOURNAL.org" "New Ideas")))
> -------------------------------------------------------------------------------------
> 
> 
> 
> 
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-remember
  2009-01-19 20:22 ` Nick Dokos
@ 2009-01-19 20:32   ` Mark Elston
       [not found]     ` <9099.1232399183@alphaville.usa.hp.com>
  0 siblings, 1 reply; 7+ messages in thread
From: Mark Elston @ 2009-01-19 20:32 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: Org Mode List

Nick,

It helps with the first problem, the autoload problem.  I didn't see
this in the manual anywhere.

However, while it brings up a *Remember* window it doesn't populate
it with any of the templates I have set up (basically I copied what was
in the texinfo doc).  And when I write something in it and hit
C-cC-c I get an error:

   Debugger entered--Lisp error: (error "The mark is not set now, so 
there is no region")
   call-interactively(comment-region)

This is not what I expected from the docs.

Mark

* Nick Dokos wrote (on 1/19/2009 12:22 PM):
> Mark Elston <m.elston@advantest-ard.com> wrote:
> 
>> Hi,
>>
>> I am having trouble getting org-remember to work.  I have
>> (require 'org) with several other org related settings in my
>> .emacs but when I try M-x org-remember on a TODO item (or anywhere
>> else) I get:
>>
>>
>> Emacs 22.3.1
>> Windows XP
>> org-mode 6.17c
>>
> 
> Does replacing 
> 
>      (require 'org)
> 
> with
> 
>      (require 'org-install)
> 
> help?
> 
> 
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Problem with org-remember
  2009-01-19 20:13 Problem " Mark Elston
@ 2009-01-19 20:22 ` Nick Dokos
  2009-01-19 20:32   ` Mark Elston
  0 siblings, 1 reply; 7+ messages in thread
From: Nick Dokos @ 2009-01-19 20:22 UTC (permalink / raw)
  To: m.elston; +Cc: Org Mode List

Mark Elston <m.elston@advantest-ard.com> wrote:

> Hi,
> 
> I am having trouble getting org-remember to work.  I have
> (require 'org) with several other org related settings in my
> .emacs but when I try M-x org-remember on a TODO item (or anywhere
> else) I get:
> 
> 
> Emacs 22.3.1
> Windows XP
> org-mode 6.17c
> 

Does replacing 

     (require 'org)

with

     (require 'org-install)

help?

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Problem with org-remember
@ 2009-01-19 20:13 Mark Elston
  2009-01-19 20:22 ` Nick Dokos
  0 siblings, 1 reply; 7+ messages in thread
From: Mark Elston @ 2009-01-19 20:13 UTC (permalink / raw)
  To: Org Mode List

Hi,

I am having trouble getting org-remember to work.  I have
(require 'org) with several other org related settings in my
.emacs but when I try M-x org-remember on a TODO item (or anywhere
else) I get:

   Debugger entered--Lisp error: (error "Autoloading failed to define 
function org-remember")
     signal(error ("Autoloading failed to define function org-remember"))
     error("%s" "Autoloading failed to define function org-remember")
     (condition-case act-on-choice (let (...) (setq 
icicle-candidate-action-fn nil) (funcall ... cmd-choice)) (quit 
(icicle-try-switch-buffer orig-buff) nil) (error 
(icicle-try-switch-buffer orig-buff) nil (error "%s" ...)))
     (let* ((orig-buff ...) (orig-window ...) (use-file-dialog nil) 
(last-command last-command) new-last-cmd (icicle-candidate-action-fn 
...)) nil (condition-case act-on-choice (let ... ... ...) (quit ... nil) 
(error ... nil ...)) (setq this-command new-last-cmd))
     icicle-execute-extended-command()
     call-interactively(icicle-execute-extended-command)

If I don't load the icicle package I get roughly the same error:

   Debugger entered--Lisp error: (error "Autoloading failed to define 
function org-remember")
     execute-extended-command(nil)
     call-interactively(execute-extended-command)

If I load-library org-remember then I can call the function without
error but it doesn't populate the buffer with anything and if I enter
some text and type C-cC-c I get an error about a nonexistent region.

Any ideas?

Emacs 22.3.1
Windows XP
org-mode 6.17c

Mark

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2010-03-06 10:34 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-03-06  2:40 problem with org-remember Christian Wittern
2010-03-06 10:34 ` Christian Wittern
  -- strict thread matches above, loose matches on Subject: below --
2009-01-19 20:13 Problem " Mark Elston
2009-01-19 20:22 ` Nick Dokos
2009-01-19 20:32   ` Mark Elston
     [not found]     ` <9099.1232399183@alphaville.usa.hp.com>
2009-01-19 21:19       ` Mark Elston
     [not found]         ` <9717.1232400732@alphaville.usa.hp.com>
2009-01-19 22:09           ` Mark Elston

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).