emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* errors in org-mode with indentation
@ 2011-09-21 23:15 Thomas Faurbye Nielsen
  2011-09-22  0:14 ` Nick Dokos
  0 siblings, 1 reply; 4+ messages in thread
From: Thomas Faurbye Nielsen @ 2011-09-21 23:15 UTC (permalink / raw)
  To: emacs-orgmode

Hi,

Earlier today my org-mode indentation was working just perfectly.

But now, every time I try to indent a new line with some text on it, or make a 
newline-and-indent I end up with the following error.

org-indent-line-to: Wrong type argument: number-or-marker-p, nil

Any ideas about why this error is there?

Thomas

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: errors in org-mode with indentation
  2011-09-21 23:15 errors in org-mode with indentation Thomas Faurbye Nielsen
@ 2011-09-22  0:14 ` Nick Dokos
  2011-09-22  0:29   ` Thomas Faurbye Nielsen
  0 siblings, 1 reply; 4+ messages in thread
From: Nick Dokos @ 2011-09-22  0:14 UTC (permalink / raw)
  To: Thomas Faurbye Nielsen; +Cc: nicholas.dokos, emacs-orgmode

Thomas Faurbye Nielsen <archanium@gmail.com> wrote:

> Hi,
> 
> Earlier today my org-mode indentation was working just perfectly.
> 
> But now, every time I try to indent a new line with some text on it, or make a 
> newline-and-indent I end up with the following error.
> 
> org-indent-line-to: Wrong type argument: number-or-marker-p, nil
> 
> Any ideas about why this error is there?
> 

If it was working earlier today and you have not updated anything, then
your current session might have gotten curdled. Restart your emacs and
see if it goes away.

If not, post a backtrace: see section 1.4, "Feedback" of the org manual
on how to produce one.

Nick

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: errors in org-mode with indentation
  2011-09-22  0:14 ` Nick Dokos
@ 2011-09-22  0:29   ` Thomas Faurbye Nielsen
  2011-09-22  2:20     ` Nick Dokos
  0 siblings, 1 reply; 4+ messages in thread
From: Thomas Faurbye Nielsen @ 2011-09-22  0:29 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 926 bytes --]

Hi Nick

I've just updated my org-mode installation, and tried restarting my computer
too.

The error still happens, and I have attached the backtrace.

On Thu, Sep 22, 2011 at 2:14 AM, Nick Dokos <nicholas.dokos@hp.com> wrote:

> Thomas Faurbye Nielsen <archanium@gmail.com> wrote:
>
> > Hi,
> >
> > Earlier today my org-mode indentation was working just perfectly.
> >
> > But now, every time I try to indent a new line with some text on it, or
> make a
> > newline-and-indent I end up with the following error.
> >
> > org-indent-line-to: Wrong type argument: number-or-marker-p, nil
> >
> > Any ideas about why this error is there?
> >
>
> If it was working earlier today and you have not updated anything, then
> your current session might have gotten curdled. Restart your emacs and
> see if it goes away.
>
> If not, post a backtrace: see section 1.4, "Feedback" of the org manual
> on how to produce one.
>
> Nick
>
>

[-- Attachment #1.2: Type: text/html, Size: 1412 bytes --]

[-- Attachment #2: error.bug --]
[-- Type: application/octet-stream, Size: 13757 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: errors in org-mode with indentation
  2011-09-22  0:29   ` Thomas Faurbye Nielsen
@ 2011-09-22  2:20     ` Nick Dokos
  0 siblings, 0 replies; 4+ messages in thread
From: Nick Dokos @ 2011-09-22  2:20 UTC (permalink / raw)
  To: Thomas Faurbye Nielsen; +Cc: nicholas.dokos, emacs-orgmode

Thomas Faurbye Nielsen <archanium@gmail.com> wrote:

> Hi Nick
> 
> I've just updated my org-mode installation, and tried restarting my computer too.
> 
> The error still happens, and I have attached the backtrace.

What version of emacs are you running?

The top of the backtrace says

Debugger entered--Lisp error: (wrong-type-argument number-or-marker-p nil)
  indent-line-to(2)
  (if (featurep (quote xemacs)) (org-xemacs-without-invisibility (indent-line-to column)) (indent-line-to column))
  org-indent-line-to(2)

so if the number-or-marker-p applies to the 2, i.e. the argument of
indent-line-to, there is a serious bug in emacs. I assume that that's
not the case - indeed

  (number-or-marker-p 2)

returns t (you might want to try it and verify that that is indeed the
case for you).

If it's something else, then you might want to try evaluating the following:

  (indent-line-to 2)

If that gives you an error, then org is exonerated. In that case, you
might want to load an uncompiled indent.el and step through the function
with edebug (or see if you get a backtrace when evaluating the form
above).

But I must say, this is pretty weird.

Nick

> 
> On Thu, Sep 22, 2011 at 2:14 AM, Nick Dokos <nicholas.dokos@hp.com> wrote:
> 
>     Thomas Faurbye Nielsen <archanium@gmail.com> wrote:
>    
>     > Hi,
>     >
>     > Earlier today my org-mode indentation was working just perfectly.
>     >
>     > But now, every time I try to indent a new line with some text on it, or make a
>     > newline-and-indent I end up with the following error.
>     >
>     > org-indent-line-to: Wrong type argument: number-or-marker-p, nil
>     >
>     > Any ideas about why this error is there?
>     >
>    
>     If it was working earlier today and you have not updated anything, then
>     your current session might have gotten curdled. Restart your emacs and
>     see if it goes away.
>    
>     If not, post a backtrace: see section 1.4, "Feedback" of the org manual
>     on how to produce one.
>    
>     Nick
> 
> 
> ----------------------------------------------------
> Alternatives:
> 
> ----------------------------------------------------

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2011-09-22  2:20 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-21 23:15 errors in org-mode with indentation Thomas Faurbye Nielsen
2011-09-22  0:14 ` Nick Dokos
2011-09-22  0:29   ` Thomas Faurbye Nielsen
2011-09-22  2:20     ` Nick Dokos

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).