emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Bernd Weiss <bernd.weiss@uni-koeln.de>
To: Eric S Fraga <e.fraga@ucl.ac.uk>
Cc: emacs-orgmode@gnu.org
Subject: Re: [babel] Maxima code blocks do not work
Date: Mon, 27 Jun 2011 08:22:52 -0400	[thread overview]
Message-ID: <4E08761C.8040900@uni-koeln.de> (raw)
In-Reply-To: <874o3bwu3c.fsf@ucl.ac.uk>

Am 27.06.2011 04:34, schrieb Eric S Fraga:
> Bernd Weiss <bernd.weiss@uni-koeln.de> writes:
> 
>> Dear all,
>>
>> The follwing Maxima code block does not work:
>>
>> #+begin_src maxima
>> 1+1;
>> #+end_src
>> #+results:
>> #+begin_example
>> incorrect syntax: / is not a prefix operator
>> incorrect syntax: GuM is not an infix operator
>> parser: incomplete number; missing exponent?
>>  -- an error. To debug this try: debugmode(true);
>> incorrect syntax: Too many )'s
>> incorrect syntax: Premature termination of input at $.
>> Maxima encountered a Lisp error:
>>  parser: end of file while scanning expression.
>> Automatically continuing.
>> To enable the Lisp debugger set *debugger-hook* to nil.
>> #+end_example
> 
> Strange.  I don't get this at all.  In fact, I get no output at all with
> your example.  If I change the code to:


Hi Eric,

Thanks for your answer!


> #+begin_src maxima
> a: 1+1;
> print(a);
> #+end_src
> 
> then I get:
> 
> #+results:
> : 2 
> 
> 
>> Package: Org-mode version 7.5 (release_7.5.435.gd3100)
> 
> I am running a newer version of org than you are so maybe update?  I am
> also on emacs 24.

I updated org (again, now it's Org-mode version 7.5
(release_7.5.461.g6d18)), I switched to Emacs 24 but to no avail. I also
tried to use the debugger but this does not seem to be an error...

Debug on Error enabled globally
executing Maxima code block...
executing Maxima source code block
maxima --very-quiet -r
'batchload("c:/Users/weiss/AppData/Local/Temp/babel-209000BH/maxima-20900VN1")$'
nil
Code block evaluation complete.

I also realized that the 'error message' changes every time I try to run
the code block:

#+results:
: incorrect syntax: / is not a prefix operator
: incorrect syntax: aLH is not an infix operator
: incorrect syntax: hCp is not an infix operator
: incorrect syntax: Premature termination of input at $.
: Maxima encountered a Lisp error:
:  parser: end of file while scanning expression.
: Automatically continuing.
: To enable the Lisp debugger set *debugger-hook* to nil.

This message is 'related' (see lines 3 "aLH is not an infix operator"
and 4 "hCp is not an infix operator") to the following Maxima call
("aLH/maxima-17716hCp"):

maxima --very-quiet -r
'batchload("c:/Users/weiss/AppData/Local/Temp/babel-17716aLH/maxima-17716hCp")$'
nil

Unfortunately, my elisp knowledge is too low to understand what's going
on in ob-maxima.el. Is it a MS-Windows-thing ('/' vs '\')?

To be honest, running Maxima in org in not so important for me. As long
as R works, everything is fine :-)

Thanks,

Bernd

  reply	other threads:[~2011-06-27 12:23 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-24 18:07 Bernd Weiss
2011-06-27  8:34 ` Eric S Fraga
2011-06-27 12:22   ` Bernd Weiss [this message]
2011-06-27 14:32     ` Eric S Fraga
2011-06-27 20:37 Bernd Weiss
2011-06-29 16:32 ` Eric S Fraga

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4E08761C.8040900@uni-koeln.de \
    --to=bernd.weiss@uni-koeln.de \
    --cc=e.fraga@ucl.ac.uk \
    --cc=emacs-orgmode@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).