emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: "Berry, Charles" via "General discussions about Org-mode." <emacs-orgmode@gnu.org>
To: Michael Welle <mwe012008@gmx.net>
Cc: "emacs-orgmode@gnu.org" <emacs-orgmode@gnu.org>
Subject: Re: org-sbe and code blocks in a different files
Date: Thu, 9 Jul 2020 16:43:47 +0000	[thread overview]
Message-ID: <4D4F25E2-68A1-4BC2-B0E1-8D2044A5E318@health.ucsd.edu> (raw)
In-Reply-To: <87imexdv1m.fsf@luisa.c0t0d0s0.de>



> On Jul 9, 2020, at 12:09 AM, Michael Welle <mwe012008@gmx.net> wrote:
> 
> Hi Douglas,
> 
> Douglas Perrin <doug2024@gmail.com> writes:
> 
>> Hi Michael,
>> Maybe I am not understanding what you want to do but I use
>> org-babel-lob-ingest/org-sbe to execute blocks from other files on
>> start-up like this:
>> # Local Variables:
>> # eval: (org-babel-lob-ingest "Template-Loader.org")
>> # eval: (org-sbe "Init-Template") ;; the name of a block
>> in Template-Loader.org file
>> # End:
>> 
>> I assume this means that org-sbe can see the block names from the other
>> file. But I haven't tested the behavior with #call just executing elisp.
>> Doug
> thanks for bringing that up again. Your example works, of course. After
> further inspection I think that variables kill my example:
> 
> This code block comes from a file I processed with org-babel-lob-ingest.
> o-b-l-i returns the correct number of code blocks in that file and org-bab
> 
> #+name: boing
> #+begin_src elisp :var range=42
> (message "Hello, crude world: %s" range)
> #+end_src
> 
> This comes from the file where I want to use the code block:
> 
> |------------------------------------+--------|
> | <2020-02-19 Wed>--<2020-02-21 Fri> | #ERROR |
> #+TBLFM: $2='(org-sbe "boing" (range 23))
> 
> That fails. After removing the variable from the code block and from
> org-sbe it works as expected. It works as well if I copy the code block
> including the variable into the file with the table. Might be a bug or
> my own stupidity?
> 


Not stupidity. AFAICS there is no call in org-sbe to org-babel-lob-get-info, so the params are not updated.  I supposed this counts as a bug.

As a workaround

#+TBLFM: $2='(org-babel-ref-resolve "boing(range=23)")

should do.

HTH,

Chuck




  reply	other threads:[~2020-07-09 16:44 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-08 20:29 Douglas Perrin
2020-07-09  7:09 ` Michael Welle
2020-07-09 16:43   ` Berry, Charles via General discussions about Org-mode. [this message]
2020-07-09 17:17     ` Michael Welle
  -- strict thread matches above, loose matches on Subject: below --
2020-07-07 18:43 Michael Welle
2020-07-08 14:10 ` Eric S Fraga
2020-07-08 14:11 ` Eric S Fraga
2020-07-08 14:59   ` Michael Welle
2020-07-08 15:07     ` Eric S Fraga

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4D4F25E2-68A1-4BC2-B0E1-8D2044A5E318@health.ucsd.edu \
    --to=emacs-orgmode@gnu.org \
    --cc=ccberry@health.ucsd.edu \
    --cc=mwe012008@gmx.net \
    --subject='Re: org-sbe and code blocks in a different files' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).