emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Fwd: Citation in org mode does not compile
       [not found] <CAL1SgUp87tichwJhr25VpnVTwniH+ivvoxoaiL_9oqFR-Ugcgg@mail.gmail.com>
@ 2012-09-26 17:00 ` Sanjib Sikder
  2012-09-26 18:38   ` Thomas S. Dye
  0 siblings, 1 reply; 10+ messages in thread
From: Sanjib Sikder @ 2012-09-26 17:00 UTC (permalink / raw)
  To: emacs-orgmode


[-- Attachment #1.1: Type: text/plain, Size: 602 bytes --]

Hi,

I tried the whole day trying the instructions through out various web pages
to have references in scientific document without any success.

C-c C-e p produces the pdf file with question mark in place of reference.

I have attached four files.

BibAbb1.bib is my bibliography file
DOTemacs is the .emacs file
TestSciDocu.org is the org file for scientific writing
TestSciDocu.pdf is the output


Please help me in geeting the citation correctly :(

I am using emacs-snapshot on Ubuntu 12.04.

Thanks



-----------------------------
*Sanjib Sikder
*Ph.D. Fellow
Chemical Engineering
IIT Bombay*

*

[-- Attachment #1.2: Type: text/html, Size: 933 bytes --]

[-- Attachment #2: BibAbb1.bib --]
[-- Type: application/octet-stream, Size: 810 bytes --]

@ARTICLE{ashu1995molecular,
  author = {PA Ashu and JH Jefferson and AG Cullis and WE Hagston and CR Whitehouse},
  title = {Molecular dynamics simulation of (100) InGaAs/GaAs strained-layer
	relaxation processes},
  journal = {J. Cryst. Growth},
  year = {1995},
  volume = {150},
  pages = {176--179},
  owner = {ss},
  publisher = {Elsevier},
  timestamp = {2011.06.16}
}


@ARTICLE{brush1967,
  author = {Brush, S. G.},
  title = {History of the Lenz-Ising model},
  journal = {Rev. Mod. Phys.},
  year = {1967},
  volume = {39},
  pages = {883--893},
  number = {4},
  month = {Oct},
  doi = {10.1103/RevModPhys.39.883},
  file = {brush1967_History of Lenz-Ising Model.pdf:Papers/Ising Model/brush1967_History of Lenz-Ising Model.pdf:PDF},
  numpages = {10},
  publisher = {American Physical Society}
}



[-- Attachment #3: DOTemacs --]
[-- Type: application/octet-stream, Size: 6102 bytes --]


(global-visual-line-mode 1)
;;;=======================


;;;========================Inhibit start-up window ===========================================
(setq inhibit-startup-message t)
;;Following lines will get shown on start up
;; This buffer is for notes you don't want to save, and for Lisp evaluation.
;; If you want to create a file, visit that file with C-x C-f,
;; then enter the text in that file's own buffer.

;;;========================enable syntax highlighting=================================================
;;;different colour to different types of text like comments, maths etc
(global-font-lock-mode t)
;;;highlights marked regions
(setq transient-mark-mode t)
;;;========================================================================
;;;font lock, word wrap, truncate lines, fyspell...........
(add-hook 'org-mode-hook
    (lambda ()
      'turn-on-font-lock
      (setq word-wrap 1)
      (setq truncate-lines nil)
      (flyspell-mode 1)))

;;;=================================================
;;predictive
(add-to-list 'load-path "~/.emacs.d/predictive")
(add-to-list 'load-path "~/.emacs.d/predictive/texinfo")
(add-to-list 'load-path "~/.emacs.d/predictive/latex")
(add-to-list 'load-path "~/.emacs.d/predictive/html")
(require 'predictive)

;;;=================================================
;;;Recent files menu in emacs
(require 'recentf)
(recentf-mode 1)
;;;========================org mode============================


;;enable org-mode
(require 'org)

;;make org-mode work with files ending in .org
(add-to-list 'auto-mode-alist '("\\.org$" . org-mode))

;;;========================org mode Capture============================
;;;..............................................................
;;capture
(setq org-directory "~/Ubuntu One/EmacsFilesUO/OrgFilesUO/")
(setq org-default-notes-file (concat org-directory "notes.org"))
    (define-key global-map "\C-cc" 'org-capture)

;;;..........................................................
;;;org capture templates
(setq org-capture-templates
 `(
    ("n" "Notes" entry (file+datetree
               ,(concat org-directory "notes.org"))
   "* %^{Description} %^g %?
Added: %U")

     ))
;;;add more templates later
;;;......................................................
;;;create frame and close frame for capture
(defadvice org-capture-finalize
 (after delete-capture-frame activate)  
  "Advise capture-finalize to close the frame"  
  (if (equal "capture" (frame-parameter nil 'name))  
      (delete-frame)))  
  
(defadvice org-capture-destroy
 (after delete-capture-frame activate)  
  "Advise capture-destroy to close the frame"  
  (if (equal "capture" (frame-parameter nil 'name))  
      (delete-frame)))  
  
;; make the frame contain a single window. by default org-capture  
;; splits the window.  
(add-hook 'org-capture-mode-hook  
          'delete-other-windows)  
  
(defun make-capture-frame ()  
  "Create a new frame and run org-capture."  
  (interactive)  
  (make-frame '((name . "capture")
                (width . 120)
                (height . 15)))  
  (select-frame-by-name "capture")
  (setq word-wrap 1)
  (setq truncate-lines nil)
  (org-capture))  


;;;============================
(require 'org-latex)
(unless (boundp 'org-export-latex-classes)
 (setq org-export-latex-classes nil))


;;;===============Org mode reftex ==================
;;;First, we want to load to load RefTeX whenever we use org-mode. 
;;;This is well documented, and mine only differs in the citation formats 
;;;..I pass to RefTex, and my additional key binding.
(defun org-mode-reftex-setup ()
  (load-library "reftex")
  (and (buffer-file-name) (file-exists-p (buffer-file-name))
       (progn
	 ;enable auto-revert-mode to update reftex when bibtex file changes on disk
	 (global-auto-revert-mode t)
	 (reftex-parse-all)
	 ;add a custom reftex cite format to insert links
	 (reftex-set-cite-format
	  '((?b . "[[bib:%l][%l-bib]]")
	    (?n . "[[notes:%l][%l-notes]]")
	    (?p . "[[papers:%l][%l-paper]]")
	    (?t . "%t")
	    (?h . "** %t\n:PROPERTIES:\n:Custom_ID: %l\n:END:\n[[papers:%l][%l-paper]]")))))
  (define-key org-mode-map (kbd "C-c )") 'reftex-citation)
  (define-key org-mode-map (kbd "C-c (") 'org-mode-reftex-search))

(add-hook 'org-mode-hook 'org-mode-reftex-setup)

;;;jump to entry
;;;The other difference I added was the binding of  ”C-c (” 
;;;to org-mode-reftex-search, which I defined earlier in my init.el. 
;;;This is the command that will jump to the entry in my org-mode file, and follows
(defun org-mode-reftex-search ()
  ;;jump to the notes for the paper pointed to at from reftex search
  (interactive)
  (org-open-link-from-string (format "[[notes:%s]]" (reftex-citation t))))

;;;===========Latex==============

(custom-set-variables
;; custom-set-variables was added by Custom.
;; If you edit it by hand, you could mess it up, so be careful.
;; Your init file should contain only one such instance.
;; If there is more than one, they won't work right.
'(TeX-PDF-mode t t)
'(TeX-source-correlate-method (quote synctex))
'(TeX-source-correlate-mode t)
'(TeX-source-correlate-start-server t)
'(TeX-view-program-list (quote (("Okular" "okular --unique %o#src:%n%b"))))
'(TeX-view-program-selection (quote ((output-pdf "Okular") ((output-dvi style-pstricks) "dvips and gv") (output-dvi "xdvi") (output-html "xdg-open"))))


'(show-paren-mode t))
(custom-set-faces
;; custom-set-faces was added by Custom.
;; If you edit it by hand, you could mess it up, so be careful.
;; Your init file should contain only one such instance.
;; If there is more than one, they won't work right.
'(default ((t (:inherit nil :stipple nil :background "white" :foreground "black" :inverse-video nil :box nil :strike-through nil :overline nil :underline nil :slant normal :weight normal :height 98 :width normal :foundry "unknown" :family "Liberation Sans")))))

;;;......................................................................................
(setq TeX-auto-save t)
(setq TeX-parse-self t)
(setq TeX-save-query nil)





;;;==================================================



[-- Attachment #4: TestSciDocu.pdf --]
[-- Type: application/pdf, Size: 76589 bytes --]

[-- Attachment #5: TestSciDocu.org --]
[-- Type: application/octet-stream, Size: 928 bytes --]




#-*- mode: org -*-
The Impact of Beer Consumption on Scientific Collaboration
#+AUTHOR: Mario Fasold
#+LATEX_HEADER: \usepackage{natbib}


* Introduction
** Previous Work
Some studies relating scientific output and beer have previously been done.
#+BEGIN_QUOTE
In Europe, most alcohol is consumed as beer and, based on well known negative effects of alcohol consumption on cognitive performance, I predicted negative correlations between beer consumption and several measures of scientific performance.
#+END_QUOTE


hi \citep{biswas2008generalized}
hello \citep{cai1992length}


* Results
** What beer should you drink
+ Becks
+ Czech Budweiser
+ Duff

#+BEGIN_EXAMPLE
Some example from a text file.
#+END_EXAMPLE

#+BEGIN_LaTeX
All lines between these markers are exported literally
#+END_LaTeX





Go to [[Introduction]]

\begin{equation}
x =\frac{a}{b}
\end{equation}

\bibliographystyle{plain}
\bibliography{BibAbb1}{}

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-26 17:00 ` Fwd: Citation in org mode does not compile Sanjib Sikder
@ 2012-09-26 18:38   ` Thomas S. Dye
  2012-09-27  2:43     ` Sanjib Sikder
  0 siblings, 1 reply; 10+ messages in thread
From: Thomas S. Dye @ 2012-09-26 18:38 UTC (permalink / raw)
  To: Sanjib Sikder; +Cc: emacs-orgmode

Aloha Sanjib Sikder,

It looks like BibTeX hasn't processed your document.

See the variable org-latex-to-pdf-process. By default I believe it just
calls pdflatex several times.  You can either insert a call to bibtex,
or use a script, like this:

(setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose --batch %f"))

hth,
Tom


Sanjib Sikder <sanjibju2002@gmail.com> writes:

> Hi,
>
> I tried the whole day trying the instructions through out various web pages
> to have references in scientific document without any success.
>
> C-c C-e p produces the pdf file with question mark in place of reference.
>
> I have attached four files.
>
> BibAbb1.bib is my bibliography file
> DOTemacs is the .emacs file
> TestSciDocu.org is the org file for scientific writing
> TestSciDocu.pdf is the output
>
>
> Please help me in geeting the citation correctly :(
>
> I am using emacs-snapshot on Ubuntu 12.04.
>
> Thanks
>
>
>
> -----------------------------
> *Sanjib Sikder
> *Ph.D. Fellow
> Chemical Engineering
> IIT Bombay*
>
> *
> Hi,I tried the whole day trying the instructions through out various web pages to have references in scientific document without any success.C-c C-e p produces the pdf file with question mark in place of reference.
>
>
> I have attached four files.BibAbb1.bib is my bibliography fileDOTemacs is the .emacs fileTestSciDocu.org is the org file for scientific writingTestSciDocu.pdf is the outputPlease help me in geeting the citation correctly :(
>
>
> I am using emacs-snapshot on Ubuntu 12.04.Thanks-----------------------------<span style="color:rgb(102,102,102)">Sanjib Sikder</span><span style="color:rgb(153,153,153)">Ph.D. Fellow
>
>
> Chemical EngineeringIIT Bombay</span>
>
>
>
>
>

-- 
Thomas S. Dye
http://www.tsdye.com

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-26 18:38   ` Thomas S. Dye
@ 2012-09-27  2:43     ` Sanjib Sikder
  2012-09-27  3:14       ` Sanjib Sikder
  2012-10-03  7:04       ` Nick Dokos
  0 siblings, 2 replies; 10+ messages in thread
From: Sanjib Sikder @ 2012-09-27  2:43 UTC (permalink / raw)
  To: Thomas S. Dye; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 2397 bytes --]

HI,

(setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose --batch
%f"))

I have incorporated above line in my .emacs file. Now the C-c C-e p is not
showing the error "Undefined citation" but the problem is still there. In
place of refrences, I am getting questions marks.

Thanks for your response.

-----------------------------
*Sanjib Sikder
*Ph.D. Fellow
Chemical Engineering
IIT Bombay*

*



On Thu, Sep 27, 2012 at 12:08 AM, Thomas S. Dye <tsd@tsdye.com> wrote:

> Aloha Sanjib Sikder,
>
> It looks like BibTeX hasn't processed your document.
>
> See the variable org-latex-to-pdf-process. By default I believe it just
> calls pdflatex several times.  You can either insert a call to bibtex,
> or use a script, like this:
>
> (setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose --batch
> %f"))
>
> hth,
> Tom
>
>
> Sanjib Sikder <sanjibju2002@gmail.com> writes:
>
> > Hi,
> >
> > I tried the whole day trying the instructions through out various web
> pages
> > to have references in scientific document without any success.
> >
> > C-c C-e p produces the pdf file with question mark in place of reference.
> >
> > I have attached four files.
> >
> > BibAbb1.bib is my bibliography file
> > DOTemacs is the .emacs file
> > TestSciDocu.org is the org file for scientific writing
> > TestSciDocu.pdf is the output
> >
> >
> > Please help me in geeting the citation correctly :(
> >
> > I am using emacs-snapshot on Ubuntu 12.04.
> >
> > Thanks
> >
> >
> >
> > -----------------------------
> > *Sanjib Sikder
> > *Ph.D. Fellow
> > Chemical Engineering
> > IIT Bombay*
> >
> > *
> > Hi,I tried the whole day trying the instructions through out various web
> pages to have references in scientific document without any success.C-c C-e
> p produces the pdf file with question mark in place of reference.
> >
> >
> > I have attached four files.BibAbb1.bib is my bibliography fileDOTemacs
> is the .emacs fileTestSciDocu.org is the org file for scientific
> writingTestSciDocu.pdf is the outputPlease help me in geeting the citation
> correctly :(
> >
> >
> > I am using emacs-snapshot on Ubuntu
> 12.04.Thanks-----------------------------<span
> style="color:rgb(102,102,102)">Sanjib Sikder</span><span
> style="color:rgb(153,153,153)">Ph.D. Fellow
> >
> >
> > Chemical EngineeringIIT Bombay</span>
> >
> >
> >
> >
> >
>
> --
> Thomas S. Dye
> http://www.tsdye.com
>

[-- Attachment #2: Type: text/html, Size: 3460 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  2:43     ` Sanjib Sikder
@ 2012-09-27  3:14       ` Sanjib Sikder
  2012-09-27  3:46         ` Yagnesh Raghava Yakkala
  2012-10-03  7:04       ` Nick Dokos
  1 sibling, 1 reply; 10+ messages in thread
From: Sanjib Sikder @ 2012-09-27  3:14 UTC (permalink / raw)
  To: Thomas S. Dye; +Cc: emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 9981 bytes --]

HI,

Just now I have found that now I am not even getting the pdf. I am pasting
the error messages below.

/usr/bin/texi2dvi: Processing /home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex ...
/usr/bin/texi2dvi: BIBINPUTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: BSTINPUTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: DVIPSHEADERS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: INDEXSTYLE='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: MFINPUTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: MPINPUTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: TEXINPUTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: TFMFONTS='.:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
/usr/bin/texi2dvi: cd /home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.t2d/pdf/build
/usr/bin/texi2dvi: Cycle 1 for /home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
/usr/bin/texi2dvi: Running rm -f TestSciDocu.tex
/usr/bin/texi2dvi: Running ln -s /home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
/usr/bin/texi2dvi: /usr/bin/texi2dvi: Running pdflatex --file-line-error
</dev/null '
onstopmode' 'This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live
2009/Debian)
entering extended mode
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang,
noh
yphenation, loaded.

(./TestSciDocu.tex (/usr/share/texmf-texlive/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texmf-texlive/tex/latex/base/size11.clo))
(/usr/share/texmf-texlive/tex/latex/base/inputenc.sty
(/usr/share/texmf-texlive/tex/latex/base/utf8.def
(/usr/share/texmf-texlive/tex/latex/base/t1enc.dfu)
(/usr/share/texmf-texlive/tex/latex/base/ot1enc.dfu)
(/usr/share/texmf-texlive/tex/latex/base/omsenc.dfu)))
(/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
(/usr/share/texmf-texlive/tex/latex/base/t1enc.def))
(/usr/share/texmf-texlive/tex/latex/base/fixltx2e.sty)
(/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
(/usr/share/texmf-texlive/tex/latex/graphics/keyval.sty)
(/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
(/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
(/etc/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf-texlive/tex/latex/pdftex-def/pdftex.def)))
(/usr/share/texmf-texlive/tex/latex/tools/longtable.sty)
(/usr/share/texmf-texlive/tex/latex/float/float.sty)
(/usr/share/texmf-texlive/tex/latex/wrapfig/wrapfig.sty)
(/usr/share/texmf-texlive/tex/latex/soul/soul.sty)
(/usr/share/texmf-texlive/tex/latex/base/textcomp.sty
(/usr/share/texmf-texlive/tex/latex/base/ts1enc.def
(/usr/share/texmf-texlive/tex/latex/base/ts1enc.dfu)))
(/usr/share/texmf-texlive/tex/latex/marvosym/marvosym.sty)
(/usr/share/texmf-texlive/tex/latex/wasysym/wasysym.sty)
(/usr/share/texmf-texlive/tex/latex/base/latexsym.sty)
(/usr/share/texmf-texlive/tex/latex/amsfonts/amssymb.sty
(/usr/share/texmf-texlive/tex/latex/amsfonts/amsfonts.sty))
(/usr/share/texmf-texlive/tex/latex/hyperref/hyperref.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/ifpdf.sty)
(/usr/share/texmf-texlive/tex/generic/oberdiek/ifvtex.sty)
(/usr/share/texmf-texlive/tex/generic/ifxetex/ifxetex.sty)
(/usr/share/texmf-texlive/tex/latex/oberdiek/hycolor.sty
(/usr/share/texmf-texlive/tex/latex/oberdiek/xcolor-patch.sty))
(/usr/share/texmf-texlive/tex/latex/hyperref/pd1enc.def)
(/usr/share/texmf-texlive/tex/generic/oberdiek/etexcmds.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/infwarerr.sty))
(/usr/share/texmf-texlive/tex/latex/latexconfig/hyperref.cfg)
(/usr/share/texmf-texlive/tex/latex/oberdiek/kvoptions.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/kvsetkeys.sty))
Implicit mode ON; LaTeX internals redefined
(/usr/share/texmf-texlive/tex/latex/ltxmisc/url.sty)
(/usr/share/texmf-texlive/tex/generic/oberdiek/bitset.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/intcalc.sty)
(/usr/share/texmf-texlive/tex/generic/oberdiek/bigintcalc.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/pdftexcmds.sty
(/usr/share/texmf-texlive/tex/generic/oberdiek/ifluatex.sty)
(/usr/share/texmf-texlive/tex/generic/oberdiek/ltxcmds.sty))))
(/usr/share/texmf-texlive/tex/generic/oberdiek/atbegshi.sty))
*hyperref using default driver hpdftex*
(/usr/share/texmf-texlive/tex/latex/hyperref/hpdftex.def)
(/usr/share/texmf-texlive/tex/latex/natbib/natbib.sty)
No file TestSciDocu.aux.
(/usr/share/texmf-texlive/tex/latex/base/ts1cmr.fd)
(/usr/share/texmf-texlive/tex/context/base/supp-pdf.mkii
[Loading MPS to PDF converter (version 2006.09.02).]
) (/usr/share/texmf-texlive/tex/latex/hyperref/nameref.sty
(/usr/share/texmf-texlive/tex/latex/oberdiek/refcount.sty))
(/usr/share/texmf-texlive/tex/latex/wasysym/uwasy.fd)
(/usr/share/texmf-texlive/tex/latex/base/ulasy.fd)
(/usr/share/texmf-texlive/tex/latex/amsfonts/umsa.fd)
(/usr/share/texmf-texlive/tex/latex/amsfonts/umsb.fd)

Package natbib Warning: Citation `biswas2008generalized' on page 1
undefined on
 input line 52.


Package natbib Warning: Citation `cai1992length' on page 1 undefined on
input l
ine 53.

(/usr/share/texmf-texlive/tex/latex/base/t1cmtt.fd)

LaTeX Warning: Hyper reference `sec-1' on page 1 undefined on input line 76.

[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]
No file TestSciDocu.bbl.
[2]

Package natbib Warning: There were undefined citations.

(./TestSciDocu.aux)

LaTeX Warning: There were undefined references.


LaTeX Warning: Label(s) may have changed. Rerun to get cross-references
right.

 )pdfTeX warning (dest): name{??} has been referenced but does not exist,
repla
ced by a fixed one

 </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ectt1095.600pk>
</home/sa
njib/.texmf-var/fonts/pk/ljfour/jknappen/ec/tcrm1095.600pk>
</home/sanjib/.texm
f-var/fonts/pk/ljfour/jknappen/ec/ecbx1095.600pk>
</home/sanjib/.texmf-var/font
s/pk/ljfour/jknappen/ec/ecrm1095.600pk>
</home/sanjib/.texmf-var/fonts/pk/ljfou
r/jknappen/ec/ecbx1200.600pk>
</home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen
/ec/ecbx1440.600pk>
</home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm12
00.600pk>
</home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm1728.600pk><
/usr/share/texmf-texlive/fonts/type1/public/amsfonts/cm/cmmi10.pfb></usr/share/
texmf-texlive/fonts/type1/public/amsfonts/cm/cmr10.pfb>
Output written on TestSciDocu.pdf (2 pages, 68665 bytes).
Transcript written on TestSciDocu.log.
/usr/bin/texi2dvi: 1: cd: can't cd to /home/sanjib/Ubuntu
/usr/bin/texi2dvi: Removing /home/sanjib/Ubuntu
One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.t2d


-----------------------------
*Sanjib Sikder
*Ph.D. Fellow
Chemical Engineering
IIT Bombay*

*



On Thu, Sep 27, 2012 at 8:13 AM, Sanjib Sikder <sanjibju2002@gmail.com>wrote:

> HI,
>
>
> (setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose --batch
> %f"))
>
> I have incorporated above line in my .emacs file. Now the C-c C-e p is not
> showing the error "Undefined citation" but the problem is still there. In
> place of refrences, I am getting questions marks.
>
> Thanks for your response.
>
>
> -----------------------------
> *Sanjib Sikder
> *Ph.D. Fellow
> Chemical Engineering
> IIT Bombay*
>
> *
>
>
>
> On Thu, Sep 27, 2012 at 12:08 AM, Thomas S. Dye <tsd@tsdye.com> wrote:
>
>> Aloha Sanjib Sikder,
>>
>> It looks like BibTeX hasn't processed your document.
>>
>> See the variable org-latex-to-pdf-process. By default I believe it just
>> calls pdflatex several times.  You can either insert a call to bibtex,
>> or use a script, like this:
>>
>> (setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose
>> --batch %f"))
>>
>> hth,
>> Tom
>>
>>
>> Sanjib Sikder <sanjibju2002@gmail.com> writes:
>>
>> > Hi,
>> >
>> > I tried the whole day trying the instructions through out various web
>> pages
>> > to have references in scientific document without any success.
>> >
>> > C-c C-e p produces the pdf file with question mark in place of
>> reference.
>> >
>> > I have attached four files.
>> >
>> > BibAbb1.bib is my bibliography file
>> > DOTemacs is the .emacs file
>> > TestSciDocu.org is the org file for scientific writing
>> > TestSciDocu.pdf is the output
>> >
>> >
>> > Please help me in geeting the citation correctly :(
>> >
>> > I am using emacs-snapshot on Ubuntu 12.04.
>> >
>> > Thanks
>> >
>> >
>> >
>> > -----------------------------
>> > *Sanjib Sikder
>> > *Ph.D. Fellow
>> > Chemical Engineering
>> > IIT Bombay*
>> >
>> > *
>> > Hi,I tried the whole day trying the instructions through out various
>> web pages to have references in scientific document without any success.C-c
>> C-e p produces the pdf file with question mark in place of reference.
>> >
>> >
>> > I have attached four files.BibAbb1.bib is my bibliography fileDOTemacs
>> is the .emacs fileTestSciDocu.org is the org file for scientific
>> writingTestSciDocu.pdf is the outputPlease help me in geeting the citation
>> correctly :(
>> >
>> >
>> > I am using emacs-snapshot on Ubuntu
>> 12.04.Thanks-----------------------------<span
>> style="color:rgb(102,102,102)">Sanjib Sikder</span><span
>> style="color:rgb(153,153,153)">Ph.D. Fellow
>> >
>> >
>> > Chemical EngineeringIIT Bombay</span>
>> >
>> >
>> >
>> >
>> >
>>
>> --
>> Thomas S. Dye
>> http://www.tsdye.com
>>
>
>

[-- Attachment #2: Type: text/html, Size: 12161 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  3:14       ` Sanjib Sikder
@ 2012-09-27  3:46         ` Yagnesh Raghava Yakkala
  2012-09-27  3:59           ` Sanjib Sikder
  2012-09-27  5:28           ` Nick Dokos
  0 siblings, 2 replies; 10+ messages in thread
From: Yagnesh Raghava Yakkala @ 2012-09-27  3:46 UTC (permalink / raw)
  To: Sanjib Sikder; +Cc: emacs-orgmode, Thomas S. Dye


Hello Sanjib,

Sanjib Sikder <sanjibju2002@gmail.com> writes:

> HI,
>
> Just now I have found that now I am not even getting the pdf. I am pasting the
> error messages below.
>
> /usr/bin/texi2dvi: Processing /home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex ...
> /usr/bin/texi2dvi: BIBINPUTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: BSTINPUTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: DVIPSHEADERS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: INDEXSTYLE='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: MFINPUTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: MPINPUTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: TEXINPUTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: TFMFONTS='.:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> /usr/bin/texi2dvi: cd /home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.t2d/pdf/build
> /usr/bin/texi2dvi: Cycle 1 for /home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
> /usr/bin/texi2dvi: Running rm -f TestSciDocu.tex
> /usr/bin/texi2dvi: Running ln -s /home/sanjib/Ubuntu
> One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
> /usr/bin/texi2dvi: /usr/bin/texi2dvi: Running pdflatex --file-line-error
> </dev/null '
> onstopmode' 'This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
> entering extended mode
> LaTeX2e <2009/09/24>
> Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang,
> noh
> yphenation, loaded.
>
> (./TestSciDocu.tex (/usr/share/texmf-texlive/tex/latex/base/article.cls
> Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
> (/usr/share/texmf-texlive/tex/latex/base/size11.clo))
> (/usr/share/texmf-texlive/tex/latex/base/inputenc.sty
> (/usr/share/texmf-texlive/tex/latex/base/utf8.def
> (/usr/share/texmf-texlive/tex/latex/base/t1enc.dfu)
> (/usr/share/texmf-texlive/tex/latex/base/ot1enc.dfu)
> (/usr/share/texmf-texlive/tex/latex/base/omsenc.dfu)))
> (/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
> (/usr/share/texmf-texlive/tex/latex/base/t1enc.def))
> (/usr/share/texmf-texlive/tex/latex/base/fixltx2e.sty)
> (/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
> (/usr/share/texmf-texlive/tex/latex/graphics/keyval.sty)
> (/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
> (/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
> (/etc/texmf/tex/latex/config/graphics.cfg)
> (/usr/share/texmf-texlive/tex/latex/pdftex-def/pdftex.def)))
> (/usr/share/texmf-texlive/tex/latex/tools/longtable.sty)
> (/usr/share/texmf-texlive/tex/latex/float/float.sty)
> (/usr/share/texmf-texlive/tex/latex/wrapfig/wrapfig.sty)
> (/usr/share/texmf-texlive/tex/latex/soul/soul.sty)
> (/usr/share/texmf-texlive/tex/latex/base/textcomp.sty
> (/usr/share/texmf-texlive/tex/latex/base/ts1enc.def
> (/usr/share/texmf-texlive/tex/latex/base/ts1enc.dfu)))
> (/usr/share/texmf-texlive/tex/latex/marvosym/marvosym.sty)
> (/usr/share/texmf-texlive/tex/latex/wasysym/wasysym.sty)
> (/usr/share/texmf-texlive/tex/latex/base/latexsym.sty)
> (/usr/share/texmf-texlive/tex/latex/amsfonts/amssymb.sty
> (/usr/share/texmf-texlive/tex/latex/amsfonts/amsfonts.sty))
> (/usr/share/texmf-texlive/tex/latex/hyperref/hyperref.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/ifpdf.sty)
> (/usr/share/texmf-texlive/tex/generic/oberdiek/ifvtex.sty)
> (/usr/share/texmf-texlive/tex/generic/ifxetex/ifxetex.sty)
> (/usr/share/texmf-texlive/tex/latex/oberdiek/hycolor.sty
> (/usr/share/texmf-texlive/tex/latex/oberdiek/xcolor-patch.sty))
> (/usr/share/texmf-texlive/tex/latex/hyperref/pd1enc.def)
> (/usr/share/texmf-texlive/tex/generic/oberdiek/etexcmds.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/infwarerr.sty))
> (/usr/share/texmf-texlive/tex/latex/latexconfig/hyperref.cfg)
> (/usr/share/texmf-texlive/tex/latex/oberdiek/kvoptions.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/kvsetkeys.sty))
> Implicit mode ON; LaTeX internals redefined
> (/usr/share/texmf-texlive/tex/latex/ltxmisc/url.sty)
> (/usr/share/texmf-texlive/tex/generic/oberdiek/bitset.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/intcalc.sty)
> (/usr/share/texmf-texlive/tex/generic/oberdiek/bigintcalc.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/pdftexcmds.sty
> (/usr/share/texmf-texlive/tex/generic/oberdiek/ifluatex.sty)
> (/usr/share/texmf-texlive/tex/generic/oberdiek/ltxcmds.sty))))
> (/usr/share/texmf-texlive/tex/generic/oberdiek/atbegshi.sty))
> *hyperref using default driver hpdftex*
> (/usr/share/texmf-texlive/tex/latex/hyperref/hpdftex.def)
> (/usr/share/texmf-texlive/tex/latex/natbib/natbib.sty)
> No file TestSciDocu.aux.
> (/usr/share/texmf-texlive/tex/latex/base/ts1cmr.fd)
> (/usr/share/texmf-texlive/tex/context/base/supp-pdf.mkii
> [Loading MPS to PDF converter (version 2006.09.02).]
> ) (/usr/share/texmf-texlive/tex/latex/hyperref/nameref.sty
> (/usr/share/texmf-texlive/tex/latex/oberdiek/refcount.sty))
> (/usr/share/texmf-texlive/tex/latex/wasysym/uwasy.fd)
> (/usr/share/texmf-texlive/tex/latex/base/ulasy.fd)
> (/usr/share/texmf-texlive/tex/latex/amsfonts/umsa.fd)
> (/usr/share/texmf-texlive/tex/latex/amsfonts/umsb.fd)
>
> Package natbib Warning: Citation `biswas2008generalized' on page 1 undefined
> on
> input line 52.
>
> Package natbib Warning: Citation `cai1992length' on page 1 undefined on input
> l
> ine 53.
>
> (/usr/share/texmf-texlive/tex/latex/base/t1cmtt.fd)
>
> LaTeX Warning: Hyper reference `sec-1' on page 1 undefined on input line 76.
>
> [1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]
> No file TestSciDocu.bbl.
> [2]
>
> Package natbib Warning: There were undefined citations.
>
> (./TestSciDocu.aux)
>
> LaTeX Warning: There were undefined references.
>
> LaTeX Warning: Label(s) may have changed. Rerun to get cross-references right.
>
> )pdfTeX warning (dest): name{??} has been referenced but does not exist, repla
> ced by a fixed one
>
> </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ectt1095.600pk> </home/sa
> njib/.texmf-var/fonts/pk/ljfour/jknappen/ec/tcrm1095.600pk>
> </home/sanjib/.texm
> f-var/fonts/pk/ljfour/jknappen/ec/ecbx1095.600pk>
> </home/sanjib/.texmf-var/font
> s/pk/ljfour/jknappen/ec/ecrm1095.600pk>
> </home/sanjib/.texmf-var/fonts/pk/ljfou
> r/jknappen/ec/ecbx1200.600pk>
> </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen
> /ec/ecbx1440.600pk>
> </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm12
> 00.600pk>
> </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm1728.600pk><
> /usr/share/texmf-texlive/fonts/type1/public/amsfonts/cm/cmmi10.pfb></usr/share/
> texmf-texlive/fonts/type1/public/amsfonts/cm/cmr10.pfb>
> Output written on TestSciDocu.pdf (2 pages, 68665 bytes).
> Transcript written on TestSciDocu.log.
> /usr/bin/texi2dvi: 1: cd: can't cd to /home/sanjib/Ubuntu
                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Seems problem with texi2dvi, unable to handle spaces in the path ("Ubuntu One"
has space).I haven't followed the discussion. I am not sure why you have texi2dvi in the
processes list. 

I set org-latex-to-pdf-process to the following whenever I want bibtex to
process the exported document.

--8<---------------cut here---------------start------------->8---
(setq org-latex-to-pdf-process 
      '("pdflatex -interaction nonstopmode %b"
        "/usr/bin/bibtex %b"
        "pdflatex -interaction nonstopmode %b"
        "pdflatex -interaction nonstopmode %b"))
--8<---------------cut here---------------end--------------->8---


Thanks.,
--
ఎందరో మహానుభావులు అందరికి వందనములు
YYR

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  3:46         ` Yagnesh Raghava Yakkala
@ 2012-09-27  3:59           ` Sanjib Sikder
  2012-09-27  5:16             ` Yagnesh Raghava Yakkala
  2012-09-27  5:28           ` Nick Dokos
  1 sibling, 1 reply; 10+ messages in thread
From: Sanjib Sikder @ 2012-09-27  3:59 UTC (permalink / raw)
  To: Yagnesh Raghava Yakkala; +Cc: emacs-orgmode, Thomas S. Dye

[-- Attachment #1: Type: text/plain, Size: 9663 bytes --]

HI Yagnesh,

I have tried with

(setq org-latex-to-pdf-process
      '("pdflatex -interaction nonstopmode %b"
        "/usr/bin/bibtex %b"
        "pdflatex -interaction nonstopmode %b"
        "pdflatex -interaction nonstopmode %b"))

and the problem seems solved.

I can see there are two instances of emacs one is Emacs Snapshot (GTK) and
the other is Emacs Snapshot (Client). The GTK is properly producing the pdf
with references.

What is the difference between clint and GTK? Which on shall I use and when
?

Thanks a lot. :)

-----------------------------
*Sanjib Sikder
*Ph.D. Fellow
Chemical Engineering
IIT Bombay*

*



On Thu, Sep 27, 2012 at 9:16 AM, Yagnesh Raghava Yakkala <hi@yagnesh.org>wrote:

>
> Hello Sanjib,
>
> Sanjib Sikder <sanjibju2002@gmail.com> writes:
>
> > HI,
> >
> > Just now I have found that now I am not even getting the pdf. I am
> pasting the
> > error messages below.
> >
> > /usr/bin/texi2dvi: Processing /home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex ...
> > /usr/bin/texi2dvi: BIBINPUTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: BSTINPUTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: DVIPSHEADERS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: INDEXSTYLE='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: MFINPUTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: MPINPUTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: TEXINPUTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: TFMFONTS='.:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB:/home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB::'
> > /usr/bin/texi2dvi: cd /home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.t2d/pdf/build
> > /usr/bin/texi2dvi: Cycle 1 for /home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
> > /usr/bin/texi2dvi: Running rm -f TestSciDocu.tex
> > /usr/bin/texi2dvi: Running ln -s /home/sanjib/Ubuntu
> > One/EmacsFilesUO/OrgFilesUO/PhD_IITB/TestSciDocu.tex
> > /usr/bin/texi2dvi: /usr/bin/texi2dvi: Running pdflatex --file-line-error
> > </dev/null '
> > onstopmode' 'This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live
> 2009/Debian)
> > entering extended mode
> > LaTeX2e <2009/09/24>
> > Babel <v3.8l> and hyphenation patterns for english, usenglishmax,
> dumylang,
> > noh
> > yphenation, loaded.
> >
> > (./TestSciDocu.tex (/usr/share/texmf-texlive/tex/latex/base/article.cls
> > Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
> > (/usr/share/texmf-texlive/tex/latex/base/size11.clo))
> > (/usr/share/texmf-texlive/tex/latex/base/inputenc.sty
> > (/usr/share/texmf-texlive/tex/latex/base/utf8.def
> > (/usr/share/texmf-texlive/tex/latex/base/t1enc.dfu)
> > (/usr/share/texmf-texlive/tex/latex/base/ot1enc.dfu)
> > (/usr/share/texmf-texlive/tex/latex/base/omsenc.dfu)))
> > (/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
> > (/usr/share/texmf-texlive/tex/latex/base/t1enc.def))
> > (/usr/share/texmf-texlive/tex/latex/base/fixltx2e.sty)
> > (/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
> > (/usr/share/texmf-texlive/tex/latex/graphics/keyval.sty)
> > (/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
> > (/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
> > (/etc/texmf/tex/latex/config/graphics.cfg)
> > (/usr/share/texmf-texlive/tex/latex/pdftex-def/pdftex.def)))
> > (/usr/share/texmf-texlive/tex/latex/tools/longtable.sty)
> > (/usr/share/texmf-texlive/tex/latex/float/float.sty)
> > (/usr/share/texmf-texlive/tex/latex/wrapfig/wrapfig.sty)
> > (/usr/share/texmf-texlive/tex/latex/soul/soul.sty)
> > (/usr/share/texmf-texlive/tex/latex/base/textcomp.sty
> > (/usr/share/texmf-texlive/tex/latex/base/ts1enc.def
> > (/usr/share/texmf-texlive/tex/latex/base/ts1enc.dfu)))
> > (/usr/share/texmf-texlive/tex/latex/marvosym/marvosym.sty)
> > (/usr/share/texmf-texlive/tex/latex/wasysym/wasysym.sty)
> > (/usr/share/texmf-texlive/tex/latex/base/latexsym.sty)
> > (/usr/share/texmf-texlive/tex/latex/amsfonts/amssymb.sty
> > (/usr/share/texmf-texlive/tex/latex/amsfonts/amsfonts.sty))
> > (/usr/share/texmf-texlive/tex/latex/hyperref/hyperref.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/ifpdf.sty)
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/ifvtex.sty)
> > (/usr/share/texmf-texlive/tex/generic/ifxetex/ifxetex.sty)
> > (/usr/share/texmf-texlive/tex/latex/oberdiek/hycolor.sty
> > (/usr/share/texmf-texlive/tex/latex/oberdiek/xcolor-patch.sty))
> > (/usr/share/texmf-texlive/tex/latex/hyperref/pd1enc.def)
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/etexcmds.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/infwarerr.sty))
> > (/usr/share/texmf-texlive/tex/latex/latexconfig/hyperref.cfg)
> > (/usr/share/texmf-texlive/tex/latex/oberdiek/kvoptions.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/kvsetkeys.sty))
> > Implicit mode ON; LaTeX internals redefined
> > (/usr/share/texmf-texlive/tex/latex/ltxmisc/url.sty)
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/bitset.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/intcalc.sty)
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/bigintcalc.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/pdftexcmds.sty
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/ifluatex.sty)
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/ltxcmds.sty))))
> > (/usr/share/texmf-texlive/tex/generic/oberdiek/atbegshi.sty))
> > *hyperref using default driver hpdftex*
> > (/usr/share/texmf-texlive/tex/latex/hyperref/hpdftex.def)
> > (/usr/share/texmf-texlive/tex/latex/natbib/natbib.sty)
> > No file TestSciDocu.aux.
> > (/usr/share/texmf-texlive/tex/latex/base/ts1cmr.fd)
> > (/usr/share/texmf-texlive/tex/context/base/supp-pdf.mkii
> > [Loading MPS to PDF converter (version 2006.09.02).]
> > ) (/usr/share/texmf-texlive/tex/latex/hyperref/nameref.sty
> > (/usr/share/texmf-texlive/tex/latex/oberdiek/refcount.sty))
> > (/usr/share/texmf-texlive/tex/latex/wasysym/uwasy.fd)
> > (/usr/share/texmf-texlive/tex/latex/base/ulasy.fd)
> > (/usr/share/texmf-texlive/tex/latex/amsfonts/umsa.fd)
> > (/usr/share/texmf-texlive/tex/latex/amsfonts/umsb.fd)
> >
> > Package natbib Warning: Citation `biswas2008generalized' on page 1
> undefined
> > on
> > input line 52.
> >
> > Package natbib Warning: Citation `cai1992length' on page 1 undefined on
> input
> > l
> > ine 53.
> >
> > (/usr/share/texmf-texlive/tex/latex/base/t1cmtt.fd)
> >
> > LaTeX Warning: Hyper reference `sec-1' on page 1 undefined on input line
> 76.
> >
> > [1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]
> > No file TestSciDocu.bbl.
> > [2]
> >
> > Package natbib Warning: There were undefined citations.
> >
> > (./TestSciDocu.aux)
> >
> > LaTeX Warning: There were undefined references.
> >
> > LaTeX Warning: Label(s) may have changed. Rerun to get cross-references
> right.
> >
> > )pdfTeX warning (dest): name{??} has been referenced but does not exist,
> repla
> > ced by a fixed one
> >
> > </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ectt1095.600pk>
> </home/sa
> > njib/.texmf-var/fonts/pk/ljfour/jknappen/ec/tcrm1095.600pk>
> > </home/sanjib/.texm
> > f-var/fonts/pk/ljfour/jknappen/ec/ecbx1095.600pk>
> > </home/sanjib/.texmf-var/font
> > s/pk/ljfour/jknappen/ec/ecrm1095.600pk>
> > </home/sanjib/.texmf-var/fonts/pk/ljfou
> > r/jknappen/ec/ecbx1200.600pk>
> > </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen
> > /ec/ecbx1440.600pk>
> > </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm12
> > 00.600pk>
> > </home/sanjib/.texmf-var/fonts/pk/ljfour/jknappen/ec/ecrm1728.600pk><
> >
> /usr/share/texmf-texlive/fonts/type1/public/amsfonts/cm/cmmi10.pfb></usr/share/
> > texmf-texlive/fonts/type1/public/amsfonts/cm/cmr10.pfb>
> > Output written on TestSciDocu.pdf (2 pages, 68665 bytes).
> > Transcript written on TestSciDocu.log.
> > /usr/bin/texi2dvi: 1: cd: can't cd to /home/sanjib/Ubuntu
>                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> Seems problem with texi2dvi, unable to handle spaces in the path ("Ubuntu
> One"
> has space).I haven't followed the discussion. I am not sure why you have
> texi2dvi in the
> processes list.
>
> I set org-latex-to-pdf-process to the following whenever I want bibtex to
> process the exported document.
>
> --8<---------------cut here---------------start------------->8---
> (setq org-latex-to-pdf-process
>       '("pdflatex -interaction nonstopmode %b"
>         "/usr/bin/bibtex %b"
>         "pdflatex -interaction nonstopmode %b"
>         "pdflatex -interaction nonstopmode %b"))
> --8<---------------cut here---------------end--------------->8---
>
>
> Thanks.,
> --
> ఎందరో మహానుభావులు అందరికి వందనములు
> YYR
>

[-- Attachment #2: Type: text/html, Size: 11385 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  3:59           ` Sanjib Sikder
@ 2012-09-27  5:16             ` Yagnesh Raghava Yakkala
  0 siblings, 0 replies; 10+ messages in thread
From: Yagnesh Raghava Yakkala @ 2012-09-27  5:16 UTC (permalink / raw)
  To: Sanjib Sikder; +Cc: emacs-orgmode, Thomas S. Dye


Hello Sanjib,

Sanjib Sikder <sanjibju2002@gmail.com> writes:

> HI Yagnesh,
>
> I have tried with 
>
> (setq org-latex-to-pdf-process
> '("pdflatex -interaction nonstopmode %b"
> "/usr/bin/bibtex %b"
> "pdflatex -interaction nonstopmode %b"
> "pdflatex -interaction nonstopmode %b"))
>
> and the problem seems solved.
>
> I can see there are two instances of emacs one is Emacs Snapshot (GTK) and the
> other is Emacs Snapshot (Client). The GTK is properly producing the pdf with
> references.


> What is the difference between clint and GTK? Which on shall I use and when ?

I am not sure what you mean by instance here (from terminal ps command?). 

--8<---------------cut here---------------start------------->8---
okhotsk19:~$ ps aux | grep emacs
Grepping for processes matching emacs...
yagnesh    993  1.1  4.8 364704 99604 pts/0    S    12:59   0:46 emacs
yagnesh   5300  0.1  0.0   4024   596 pts/4    S+   14:06   0:00 emacsclient -tc
--8<---------------cut here---------------end--------------->8---

both emacs and emacsclient would/should behave the same way (mostly).

Thanks.,
-- 
ఎందరో మహానుభావులు అందరికి వందనములు
YYR

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  3:46         ` Yagnesh Raghava Yakkala
  2012-09-27  3:59           ` Sanjib Sikder
@ 2012-09-27  5:28           ` Nick Dokos
  1 sibling, 0 replies; 10+ messages in thread
From: Nick Dokos @ 2012-09-27  5:28 UTC (permalink / raw)
  To: Yagnesh Raghava Yakkala; +Cc: emacs-orgmode, Thomas S. Dye, Sanjib Sikder

Yagnesh Raghava Yakkala <hi@yagnesh.org> wrote:

> Seems problem with texi2dvi, unable to handle spaces in the path
> ("Ubuntu One" has space).I haven't followed the discussion. I am not
> sure why you have texi2dvi in the processes list.

texi2dvi is supposed to take care of things like how many times one
has to call pdflatex, whether to call bibtex etc. It would be the best
solution for this problem, if it didn't have a couple of problems of its
own. Maybe one of these days...

Nick

> I set org-latex-to-pdf-process to the following whenever I want bibtex to
> process the exported document.
> 
> (setq org-latex-to-pdf-process
>       '("pdflatex -interaction nonstopmode %b"
>         "/usr/bin/bibtex %b"
>         "pdflatex -interaction nonstopmode %b"
>         "pdflatex -interaction nonstopmode %b"))
> 

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-09-27  2:43     ` Sanjib Sikder
  2012-09-27  3:14       ` Sanjib Sikder
@ 2012-10-03  7:04       ` Nick Dokos
  2012-10-03  9:40         ` Sanjib Sikder
  1 sibling, 1 reply; 10+ messages in thread
From: Nick Dokos @ 2012-10-03  7:04 UTC (permalink / raw)
  To: Sanjib Sikder; +Cc: emacs-orgmode, Thomas S. Dye

Sanjib Sikder <sanjibju2002@gmail.com> wrote:

> HI,
> 
> (setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose --batch %f"))
> 
> I have incorporated above line in my .emacs file. Now the C-c C-e p is not showing the error
> "Undefined citation" but the problem is still there. In place of refrences, I am getting questions
> marks.
> 

I haven't gone through the whole thread, but I did go back and unpacked your files
from the original message. The problem there was indeed missing references:
your org file contains

,----
| hi \citep{biswas2008generalized}
| hello \citep{cai1992length}
`----


which did not match anything in the .bib file you attached to that
message. When I replaced them with the ones that *did* occur in your bib
file, like this:

--8<---------------cut here---------------start------------->8---
hi \citep{ashu1995molecular}
hello \citep{brush1967}
--8<---------------cut here---------------end--------------->8---

and I fixed a couple of things at the beginning of the file:

--8<---------------cut here---------------start------------->8---
# -*- mode: org -*-
#+TITLE: The Impact of Beer Consumption on Scientific Collaboration
--8<---------------cut here---------------end--------------->8---

everything worked fine (assuming that you added a call to bibtex
somewhere, either explicitly or by using texi2dvi, as indicated
previously).

The mode-setting line *has* to be on the first line: you can't leave
empty lines before it. The only exception is when the first line is a
shebang line, something like #! /bin/bash in a shell script: then the
mode-setting line has to be the second line. Emacs imposes this
restriction, not org.

There has to be a space after the # on that line: otherwise, it's not
interpreted as a comment and is included in the export output. That's an
org restriction.

Specifying the title is good practice, since otherwise the file name
becomes the title.

Nick

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: Fwd: Citation in org mode does not compile
  2012-10-03  7:04       ` Nick Dokos
@ 2012-10-03  9:40         ` Sanjib Sikder
  0 siblings, 0 replies; 10+ messages in thread
From: Sanjib Sikder @ 2012-10-03  9:40 UTC (permalink / raw)
  To: nicholas.dokos; +Cc: emacs-orgmode, Thomas S. Dye

[-- Attachment #1: Type: text/plain, Size: 2456 bytes --]

Hi Dokos,

I am sorry for the mistake, but what happened, in my original files, the
references are all correct but when I thought of giving examples in the
email, I did not put correct references.

Anyways, thanks for your valuable input.

-----------------------------
*Sanjib Sikder
*Ph.D. Fellow
Chemical Engineering
IIT Bombay*

*



On Wed, Oct 3, 2012 at 12:34 PM, Nick Dokos <nicholas.dokos@hp.com> wrote:

> Sanjib Sikder <sanjibju2002@gmail.com> wrote:
>
> > HI,
> >
> > (setq org-latex-to-pdf-process '("texi2dvi --pdf --clean --verbose
> --batch %f"))
> >
> > I have incorporated above line in my .emacs file. Now the C-c C-e p is
> not showing the error
> > "Undefined citation" but the problem is still there. In place of
> refrences, I am getting questions
> > marks.
> >
>
> I haven't gone through the whole thread, but I did go back and unpacked
> your files
> from the original message. The problem there was indeed missing references:
> your org file contains
>
> ,----
> | hi \citep{biswas2008generalized}
> | hello \citep{cai1992length}
> `----
>
>
> which did not match anything in the .bib file you attached to that
> message. When I replaced them with the ones that *did* occur in your bib
> file, like this:
>
> --8<---------------cut here---------------start------------->8---
> hi \citep{ashu1995molecular}
> hello \citep{brush1967}
> --8<---------------cut here---------------end--------------->8---
>
> and I fixed a couple of things at the beginning of the file:
>
> --8<---------------cut here---------------start------------->8---
> # -*- mode: org -*-
> #+TITLE: The Impact of Beer Consumption on Scientific Collaboration
> --8<---------------cut here---------------end--------------->8---
>
> everything worked fine (assuming that you added a call to bibtex
> somewhere, either explicitly or by using texi2dvi, as indicated
> previously).
>
> The mode-setting line *has* to be on the first line: you can't leave
> empty lines before it. The only exception is when the first line is a
> shebang line, something like #! /bin/bash in a shell script: then the
> mode-setting line has to be the second line. Emacs imposes this
> restriction, not org.
>
> There has to be a space after the # on that line: otherwise, it's not
> interpreted as a comment and is included in the export output. That's an
> org restriction.
>
> Specifying the title is good practice, since otherwise the file name
> becomes the title.
>
> Nick
>
>
>

[-- Attachment #2: Type: text/html, Size: 3321 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2012-10-03  9:41 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <CAL1SgUp87tichwJhr25VpnVTwniH+ivvoxoaiL_9oqFR-Ugcgg@mail.gmail.com>
2012-09-26 17:00 ` Fwd: Citation in org mode does not compile Sanjib Sikder
2012-09-26 18:38   ` Thomas S. Dye
2012-09-27  2:43     ` Sanjib Sikder
2012-09-27  3:14       ` Sanjib Sikder
2012-09-27  3:46         ` Yagnesh Raghava Yakkala
2012-09-27  3:59           ` Sanjib Sikder
2012-09-27  5:16             ` Yagnesh Raghava Yakkala
2012-09-27  5:28           ` Nick Dokos
2012-10-03  7:04       ` Nick Dokos
2012-10-03  9:40         ` Sanjib Sikder

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).