emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-calc-default-modes not found!
@ 2018-04-13 15:41 AW
  2018-04-14 19:07 ` Nick Dokos
  0 siblings, 1 reply; 3+ messages in thread
From: AW @ 2018-04-13 15:41 UTC (permalink / raw)
  To: Org Mode

Dear list!

org-version: Org mode version 9.1.9 (9.1.9-8-gf05c2e-elpa @ .../.emacs.d/elpa/
org-20180409/)

[I shortened the path]

C-h v org-calc TAB

results in [No match]

Expected result: find variable org-calc-default-modes

But I'd like to set (float 8) to (float 16) in orgtbl-mode tables, because 
when I export them to LaTex, in my case I get some rounding errors I'd like to 
avoid. 

However, I'm really concerned about the fact that the whole variable isn't 
found.

org-table.el is there and it contains the variable. I loaded org-mode via 

(add-to-list 'package-archives
 '("org" . "https://orgmode.org/elpa/") t)

No other org-mode around, as far as I can see. 

For testing  I inserted into my .emacs under custom-set-variables these lines:

'(org-calc-default-modes
   (quote
    (calc-internal-prec 12 calc-float-format
			(float 16)
			calc-angle-mode deg calc-prefer-frac nil calc-symbolic-mode nil 
calc-date-format
			(YYYY "-" MM "-" DD " " Www
			      (" " hh ":" mm))
			calc-display-working-message t)))

As far as I can see, the calculation is correct, Example:

| 105000200.77 |
| 105000400.05 |
|--------------|
| 210000600.82 |
#+TBLFM: @3$1=@1$1+@2$1

But why is the variable not found?

Regards,

Alexander

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-calc-default-modes not found!
  2018-04-13 15:41 org-calc-default-modes not found! AW
@ 2018-04-14 19:07 ` Nick Dokos
  2018-04-14 20:34   ` AW
  0 siblings, 1 reply; 3+ messages in thread
From: Nick Dokos @ 2018-04-14 19:07 UTC (permalink / raw)
  To: emacs-orgmode

AW <alexander.willand@t-online.de> writes:

> Dear list!
>
> org-version: Org mode version 9.1.9 (9.1.9-8-gf05c2e-elpa @ .../.emacs.d/elpa/
> org-20180409/)
>
> [I shortened the path]
>
> C-h v org-calc TAB
>
> results in [No match]
>
> Expected result: find variable org-calc-default-modes
>
> But I'd like to set (float 8) to (float 16) in orgtbl-mode tables, because 
> when I export them to LaTex, in my case I get some rounding errors I'd like to 
> avoid. 
>
> However, I'm really concerned about the fact that the whole variable isn't 
> found.
>
> org-table.el is there and it contains the variable. I loaded org-mode via 
>
> (add-to-list 'package-archives
>  '("org" . "https://orgmode.org/elpa/") t)
>
> No other org-mode around, as far as I can see. 
>
> For testing  I inserted into my .emacs under custom-set-variables these lines:
>
> '(org-calc-default-modes
>    (quote
>     (calc-internal-prec 12 calc-float-format
> 			(float 16)
> 			calc-angle-mode deg calc-prefer-frac nil calc-symbolic-mode nil 
> calc-date-format
> 			(YYYY "-" MM "-" DD " " Www
> 			      (" " hh ":" mm))
> 			calc-display-working-message t)))
>
> As far as I can see, the calculation is correct, Example:
>
> | 105000200.77 |
> | 105000400.05 |
> |--------------|
> | 210000600.82 |
>
> #+TBLFM: @3$1=@1$1+@2$1
>
> But why is the variable not found?
>

Just a guess.

You need to load org-table.el where the variable is defined. That file
is probably set up to be autoloaded when you invoke some table
functions, but if you have not invoked any of the autoloads yet, then
you might encounter this problem.

-- 
Nick

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-calc-default-modes not found!
  2018-04-14 19:07 ` Nick Dokos
@ 2018-04-14 20:34   ` AW
  0 siblings, 0 replies; 3+ messages in thread
From: AW @ 2018-04-14 20:34 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: Nick Dokos

Am Samstag, 14. April 2018, 21:07:34 CEST schrieb Nick Dokos:
> AW <alexander.willand@t-online.de> writes:
> > 
> > C-h v org-calc TAB
> > 
> > results in [No match]
> > 
> > Expected result: find variable org-calc-default-modes
> > 
> > 
> > But why is the variable not found?
> 
> Just a guess.
> 
> You need to load org-table.el where the variable is defined. That file
> is probably set up to be autoloaded when you invoke some table
> functions, but if you have not invoked any of the autoloads yet, then
> you might encounter this problem.

Works! Thank you! I pointed the cursor into a tabular.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-04-14 20:34 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-04-13 15:41 org-calc-default-modes not found! AW
2018-04-14 19:07 ` Nick Dokos
2018-04-14 20:34   ` AW

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).