emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: Yukio Siraichi <sir.yukio@gmail.com>
To: bzg@gnu.org
Cc: philip@crabman.me, emacs-orgmode@gnu.org
Subject: Re: When auto-fill breaks a link into multiple lines, the link is no longer displayed as a link
Date: Fri, 16 Apr 2021 13:51:19 +0900	[thread overview]
Message-ID: <236b01b2-32d7-e57e-4ec6-5c09afb5e3ef@gmail.com> (raw)
In-Reply-To: <87363u7rbn.fsf@gnu.org>

[-- Attachment #1: Type: text/plain, Size: 686 bytes --]

Hi Bastien.

I'm also having the same issue here.

Emacs: GNU Emacs 27.2.50 (build 1, x86_64-pc-linux-gnu, GTK+ Version 
3.24.5) of 2021-04-16
Package: Org mode version 9.4.4 (release_9.4.4 @ 
/home/user/.local/share/emacs/27.2.50/lisp/org/)

I've been able to reproduce with 'emacs -Q' (file is attached).
Apparently, whether emacs can display the link correctly or not depends 
on the number of characters before breaking the link with a newline.
If you remove one character before the newline, it works as expected. If 
you 'C-c C-l' in the link, it also works as expected until you close the 
file and open again, which goes back to not working.

Am I missing anything?

--

Yukio


[-- Attachment #2: test.org --]
[-- Type: text/plain, Size: 507 bytes --]

.Arbitrary 497 characters before the newline in the middle of the link...............................................................................................................................................................................................................................................................................................................................................................................................................................
[[h][The link
here]]

      reply	other threads:[~2021-04-16 12:28 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-22  9:32 Philip Blagoveschensky
2020-09-04 16:08 ` Bastien
2020-09-06 17:14   ` Philip Blagoveschensky
2020-09-06 17:22     ` Bastien
2021-04-16  4:51       ` Yukio Siraichi [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=236b01b2-32d7-e57e-4ec6-5c09afb5e3ef@gmail.com \
    --to=sir.yukio@gmail.com \
    --cc=87363u7rbn.fsf@gnu.org \
    --cc=bzg@gnu.org \
    --cc=emacs-orgmode@gnu.org \
    --cc=philip@crabman.me \
    --subject='Re: When auto-fill breaks a link into multiple lines, the link is no longer displayed as a link' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).