emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* tab at beginning of line does not indent any more
@ 2021-12-27  6:58 Mandar Mitra
  2021-12-27 15:52 ` Jose A. Ortega Ruiz
  2021-12-28  5:11 ` Mandar Mitra
  0 siblings, 2 replies; 3+ messages in thread
From: Mandar Mitra @ 2021-12-27  6:58 UTC (permalink / raw)
  To: emacs-orgmode

I have org 20210929 installed. 

With emacs -Q and (package-initialize) evaluted in the *scratch* buffer, I see the following change in behaviour:

* ABCD
<type tab here at beginning of line; nothing happens>



I'm fairly sure that, before the last upgrade, I used to get 

* ABCD
  <typing tab at beginning of line indents the line and brings it to under A>


Have other users observed this? Are you bothered by it? Is this a bug or a feature? Note I'm running with emacs -Q for the above, but I get the same behaviour with org-cycle-emulate-tab set to t or white. The information I found on the net seems to pertain to much older versions. 

Thanks,
Mandar.


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: tab at beginning of line does not indent any more
  2021-12-27  6:58 tab at beginning of line does not indent any more Mandar Mitra
@ 2021-12-27 15:52 ` Jose A. Ortega Ruiz
  2021-12-28  5:11 ` Mandar Mitra
  1 sibling, 0 replies; 3+ messages in thread
From: Jose A. Ortega Ruiz @ 2021-12-27 15:52 UTC (permalink / raw)
  To: emacs-orgmode

On Mon, Dec 27 2021, Mandar Mitra wrote:

> I have org 20210929 installed. 
>
> With emacs -Q and (package-initialize) evaluted in the *scratch*
> buffer, I see the following change in behaviour:
>
> * ABCD
> <type tab here at beginning of line; nothing happens>
>
>
>
> I'm fairly sure that, before the last upgrade, I used to get 
>
> * ABCD
>   <typing tab at beginning of line indents the line and brings it to under A>
>
>
> Have other users observed this? Are you bothered by it? Is this a bug
> or a feature? Note I'm running with emacs -Q for the above, but I get
> the same behaviour with org-cycle-emulate-tab set to t or white. The
> information I found on the net seems to pertain to much older
> versions.

i was surprised by this (new?) behaviour too.  in my case, i "fixed" it
with

      (setq org-adapt-indentation t)

if memory serves, i found about this variable in the info manual.

hope this helps,
jao
-- 
In this world, there are only two tragedies.  One is not getting
what one wants, and the other is getting it. - Oscar Wilde



^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: tab at beginning of line does not indent any more
  2021-12-27  6:58 tab at beginning of line does not indent any more Mandar Mitra
  2021-12-27 15:52 ` Jose A. Ortega Ruiz
@ 2021-12-28  5:11 ` Mandar Mitra
  1 sibling, 0 replies; 3+ messages in thread
From: Mandar Mitra @ 2021-12-28  5:11 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: jao

On Mon, Dec 27 2021, Jose A. Ortega Ruiz wrote:
> On Mon, Dec 27 2021, Mandar Mitra wrote:
> i was surprised by this (new?) behaviour too.  in my case, i "fixed" it
> with
> 
>       (setq org-adapt-indentation t)
> 
> if memory serves, i found about this variable in the info manual.
> 
> hope this helps,

Yes, this fixed the problem for me too, thanks very much!

In hindsight, seems to me that this may have been intended for people who write LaTeX (or other documents) using org-mode.


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-12-28  5:12 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-27  6:58 tab at beginning of line does not indent any more Mandar Mitra
2021-12-27 15:52 ` Jose A. Ortega Ruiz
2021-12-28  5:11 ` Mandar Mitra

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).