emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
From: David Asabina <vid@bina.me>
To: Maxim Nikulin <m.a.nikulin@gmail.com>
Cc: emacs-orgmode@gnu.org
Subject: Re: [PATCH] org-protocol: Fix missing '+' in js snippet
Date: Sun, 9 May 2021 00:32:45 +0200	[thread overview]
Message-ID: <20210508223245.jtpghgkwqgsskbcs@bina> (raw)
In-Reply-To: <cd274ad0-488e-8b52-aef0-87a2e95c8b85@gmail.com>

[-- Attachment #1: Type: text/plain, Size: 2967 bytes --]

> Thank you. However on linux there is another degree of freedom: various
> desktop environments can be different in respect to treatment of URLs before
> passing them to protocol handlers. I have tried KDE and a kind of
> minimalistic setup inside container (xdg-utils) so far. Anyway it is good to
> receive confirmation that it could work for other people.
Perhaps the following helps provide more context:

- OS: NixOS 20.09
- WM: Xmonad 0.15

> In the meanwhile I have realized that bug report I mentioned was for Windows
> with emacs running in WSL
> https://orgmode.org/list/87zhbq7zin.fsf@pie.tf/
I have no access to Windows setups at the moment to test that -- just
NixOS and macOS.

> P.S. Since your response was private, I am unsure if Cc:
> emacs-orgmode@gnu.org should be added.
I'm definitely new with this workflow of `git send-email` so I totally
missed that I didn't reply to the group -- I didn't reply-to-group in
mutt so that was on me.

Not sure what the policy is on keeping the signal-to-noise manageably
low on the mailing groups as I'm very much of a noob here 🤣 so I'll
just add the CC address and I trust that I'll hear when I'm contributing
to more noise than signal. 😉

On Tue, May 04, 2021 at 11:44:34PM +0700, Maxim Nikulin wrote:
> On 03/05/2021 22:25, David Asabina wrote:
> > > I have a question that is a bit off-topic in this thread however. Since you
> > > are setting up org-protocol, you may notice other issues. There were reports
> > > that two slashes after "org-protocol:" cause some problems. My guess is that
> > > capture is recognized as hostname, so another slash is inserted after it.
> > > There was a patch allowing "/" before "?" to get things work (perhaps on
> > > Windows). Could you try, please, if one or three slashes in org-protocol
> > > URIs ("org-protocol:/capture?url=..." and "org-protocol:///capture?url=...")
> > > works properly in your environment? Maybe code examples in docs would
> > > benefit from one more correction.
> > 
> > I've tried:
> > - org-protocol:/capture?template=t&url=emacs.org and
> > - org-protocol:///capture?template=t&url=emacs.org
> > and both worked like a charm on my setup (Firefox on NixOS).
> 
> Thank you. However on linux there is another degree of freedom: various
> desktop environments can be different in respect to treatment of URLs before
> passing them to protocol handlers. I have tried KDE and a kind of
> minimalistic setup inside container (xdg-utils) so far. Anyway it is good to
> receive confirmation that it could work for other people.
> 
> In the meanwhile I have realized that bug report I mentioned was for Windows
> with emacs running in WSL
> https://orgmode.org/list/87zhbq7zin.fsf@pie.tf/
> 
> P.S. Since your response was private, I am unsure if Cc:
> emacs-orgmode@gnu.org should be added.

-- 
David Asabina
@vidbina on GitHub, Twitter, Instagram, etc.

+49 1768 7062 719

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  parent reply	other threads:[~2021-05-08 22:33 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-19 10:53 David Asabina
2021-04-23 12:21 ` Maxim Nikulin
2021-04-28  5:40   ` Bastien
2021-04-28 12:42     ` Maxim Nikulin
2021-04-30  7:21       ` Bastien
2021-05-02 11:34         ` Maxim Nikulin
     [not found]   ` <20210503152514.bx5gghrqjr3vmxd7@bina>
     [not found]     ` <cd274ad0-488e-8b52-aef0-87a2e95c8b85@gmail.com>
2021-05-08 22:32       ` David Asabina [this message]
2021-04-28  5:38 ` Bastien

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.orgmode.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210508223245.jtpghgkwqgsskbcs@bina \
    --to=vid@bina.me \
    --cc=emacs-orgmode@gnu.org \
    --cc=m.a.nikulin@gmail.com \
    --subject='Re: [PATCH] org-protocol: Fix missing '\''+'\'' in js snippet' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).